Bug 242325 - Fedora 7 instalation hangs showing : "Loading pata_it821x"
Fedora 7 instalation hangs showing : "Loading pata_it821x"
Status: CLOSED DUPLICATE of bug 242229
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 07:07 EDT by Ian Gotenks
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 11:29:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Gotenks 2007-06-03 07:07:08 EDT
Environment :
-------------
Motherboard : Gigabyte GA-965G-DS3 / Core2Duo 6300 / RAM 1GB
  ATA RAID Controler : ITE IT8212 (with ATAPI Bios V1.7.1.59)
  Ethernet card : Realtek RTL8139 PCI Ethernet card
                  Intel 21041-Based PCI Ethernet card
                  Marvell Yukon 88E8053 PCI Ethernet (onboard)
  SATA Disk ST3320620NS connected to JMicron SATA port
  ATA/IDE Disk ST340016A connected to IDE port on a motherboard
  DVD-RW GSA-4167B connected to IT8212 primary   chanel
  CD-RW GCE-8400B  connected to IT8212 secondary chanel

Description of a problem:
-----------------------
Trying to install Fedora 7 (either i386 flavor or i86_64 flavor),
the instalation process hangs totaly at a very begining stage of
an instalation procedure (after kernel has succefully booted), 
showing the message on a screen :

            "Loading pata_it821x"

How reproducible:
-----------------
  Every time the instalation process starts.

Steps to Reproduce:
-------------------
1. Boot from Fedora 7 bootable DVD

  
Is there any way to succesfully install Fedora 7 in this environment ?
Comment 1 Chris Lumens 2007-06-04 10:02:31 EDT
What do you see on tty3 and tty4 when it hangs?
Comment 2 Ian Gotenks 2007-06-04 11:10:17 EDT
Unfortunately there is no way to see what is on tty3 or tty4 because I cannot
switch to them due to *total* comuter hang up :(. The hang up is so "total" that
I have to press RESET button to be able to boot the computer again. Ctrl+Alt+Del
does not work at all.

However, observing the boot process I noticed that there is a message on a 
screen at a very early stage of it, which is then erased by further "boot 
options chooser" ( sorry for my "stupid" english :) ). I was able to capture 
this message by pressing "Pause" button in an appropiate moment. 

Here is this message :

---------------
ISOLINUX 3.36 2007-02-10 isolinux: Loading spec packet failed, trying to wing it ...
isolinux: Extremely broken BIOS detected, last ditch attempt with drive = EF
isolinx: See http://syslinux.zytor.com/sbm for more information
Copyright (C) 1994-2007 H. Peter Anvin
---------------

I visited the mentioned URL but I can't say I understand anything :( 
(eg. why I should complain loudly to my vendor and/or obtain a BIOS upgrade),
because Windows 2003 and Windows XP boots and installs here without problems.
Comment 3 Ian Gotenks 2007-06-04 11:26:08 EDT
Oops !  Seems that the message comes from a bootloader, not from the kernel itself
(which simply did not started yet at this point). So I am not sure it has anything
related to "Loading pata_it821x driver" message shown later, after the kernel
booted ok and started to load other modules (???)
Comment 4 Ian Gotenks 2007-06-04 12:19:09 EDT
Ok, trying to boot with following options :

    libata.ignore_hpa=1 brokenmodules=it821x irqpoll

I was able to switch to tty3 and tty4 during boot process before it hanged up.

The last few lines on tty3 were about loading the following modules : libata,
pata_it821x, mii, 8138too, sky2, pata_jnicron, ata_piix, ahci. 
The last two lines on tty3 were :
    Ignoring host protected area
    inserted /tmp/libara.ko


The last few lines on tty4 were about configuring <6>ata1 and <6>ata2.
The last line on tty4 was :
    <5>scsi 0:0:0:0:  CD-ROM HL-DT-ST DVDRAM GSA-4167B DL12 PQ:0 ANSI:5
Comment 5 Alan Cox 2007-06-08 12:10:20 EDT
So in fact its dying when the libara module loads not it821x ?

What does brokenmodules=pata_it821x change if anything

(The boot loader message is unrelated, its indicative of poor BIOS software but
shouldn't have any effect later on as the boot loader managed to work around it
and load the kernel)
Comment 6 Ian Gotenks 2007-06-09 08:57:05 EDT
> So in fact its dying when the libara module loads not it821x ?

[ "libara" is simply a misspelled "libata" word - sorry for the confusion ]

The exact couple of lines on tty3 are :

...
loaded libata from /modules/modules.cgz
loaded pata_it821x from /modules/modules.cgz
loaded mii from /modules/modules.cgz
loaded 8139too from /modules/modules.cgz
loaded sky2 from /modules/modules.cgz
loaded pata_jmicron from /modules/modules.cgz
loaded ata_piix from /modules/modules.cgz
loaded ahci from /modules/modules.cgz
inserted /tmp/libata.ko

As you can see "inserted /tmp/libata.ko" is the last line on tty3.

> What does brokenmodules=pata_it821x change if anything

Unfortunately it changes nothing. I tried it after I posted an info
about "brokenmodules=it821x", but I did not send an update here. I
verified it again just few minutes ago. Sorry.

> (The boot loader message is unrelated, its indicative of poor BIOS software but
> shouldn't have any effect later on as the boot loader managed to work around it
> and load the kernel)

Thanks for confirmation :)
Comment 7 Matt Pounsett 2007-07-05 20:42:05 EDT
I can confirm this on additional hardware:
Motherboard:  ASUS M2A-VM / Bios: Phoenix - Awardbios 6.00PG
CPU: AMD Athlon64 X2 4200+
2x SATA disks (ST3500630AS Seagate)
Pioneer DVD-RW DVR-212D 1.15

tty1 stops at either "Loading pata_atiixp driver..." or "Loading ahci.." 

The last few lines of tty3 are:

20:40:22  INFO    : loaded r8169 from /modules/modules.cgz
20:40:22  INFO    : loaded libata from /modules/modules.cgz
20:40:22  INFO    : loaded pata_atiixp from /modules/modules.cgz
20:40:22  INFO    : loaded ahci from /modules/modules.cgz
20:40:22  INFO    : inserted /tmp/r8169.ko
20:40:22  INFO    : inserted /tmp/libata.ko

And the last few lines of tty4:

<7>libata version 2.20 loaded.
<6>ACPI: PCI Interrupt 0000:00:14.1[A] -> GSI 16 (level, low) -> IRQ 16
<6>ata1: PATA max UDMA/100 cmd 0x00000000000101f0 ctl 0x00000000000103f6 bmdma 
0x000000000001f900 irq 14
<6>ata2: PATA max UDMA/100 cmd 0x0000000000010170 ctl 0x0000000000010376 bmdma 
0x000000000001f908 irq 15
<6>scsi0 : pata_atiixp
<6>scsi1 : pata_atiixp

Comment 8 Ian Gotenks 2007-07-06 09:58:34 EDT
The sad thing is that I CANNOT use FC7 at all due to this bug. 
I guess "I got what I paid for" trying to use FC7. Fortunately
Mandriva was in place, and I am using Linux again ... But 
really I would like to return to FC
Comment 9 Alan Cox 2007-09-10 11:29:47 EDT

*** This bug has been marked as a duplicate of 242229 ***

Note You need to log in before you can comment on or make changes to this bug.