Bug 242329 - Doing F7 install which includes tclhttpd gives user UID 500
Summary: Doing F7 install which includes tclhttpd gives user UID 500
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tclhttpd (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Wart
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-03 12:21 UTC by Mike Cohler
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 3.5.1-14.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 16:47:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Cohler 2007-06-03 12:21:32 UTC
Description of problem:Doing a DVD install with including all options for the
various packages then gives tclhttpd with a user at UID 500


Version-Release number of selected component (if applicable):


How reproducible:Every time


Steps to Reproduce:
1. Start DVD install
2. For package selection choose select all available options for each package group
3. Now there is a tclhttpd user with UID 500 that conflicts with pre-existing
user UIDs that need to be brought back in to the clean install from a partition
containing existing user files.
  
Actual results:a tclhttpd user has been created which gives error messages
during boot, and also now has a user with UID of 500 which conflicts with the
UID of one existing user from previous versions of fedora that will be brought
back by adding the user lines to /etc/passwd /etc/group /etc/shadow and /etc/gshadow


Expected results: No package should create any users with UID of 500 or above so
that these numbers are reserved for new users or pre-existing users from
previous versions of the system.


Additional info:

Comment 1 Eric Poole 2007-06-18 03:34:21 UTC
Same thing happens when installing dbmail (see bug 244611).


Comment 2 Mike Cohler 2007-06-18 07:30:48 UTC
Doing grep UID_MIN /etc/login.defs
gives:

UID_MIN                   500

So this is not where the problem lies.

Comment 3 Andreas M. Kirchwitz 2007-06-18 16:33:03 UTC
Yes, that's quite confusing. In previous Fedora releases
custom UID/GID values started at 500, while 0-499 was
reserved for system resources (there's still lots of free
space within that range).

With Fedora 7, isn't there such a policy any longer?


Comment 4 Mike Cohler 2007-06-18 16:41:12 UTC
This is more than just confusing and is going to mess up a lot of people's
machines when a clean install is done, where the previous user files from an
untouched partition containing users with UID/GID starting at 500 will directly
conflict with these new users created during install.  For people looking after
machines with a lot of users this is a headache that is best avoided.

This policy to create any users with UID >=500 during install should be stopped
and return to the previous way of doing things for F8.

Comment 5 Wart 2007-06-21 00:42:08 UTC
*sigh*   That's what I get for trying to use fedora-useradd.  Tclhttpd was
intended to use a system UID, not anything in the 500+ range.  I'll fix this for
F8, and push and update for F7 that creates the account in the correct uid
range.    This will only fix it for new installations, though, it won't change
the uid for existing tclhttpd installs.  That will have to be done manually.

Comment 6 Wart 2007-07-10 20:59:09 UTC
Fixed for F8, and an update has been pushed for F-7.  Though as previously noted
this update won't be able to fix existing or new DVD installs.

Comment 7 Fedora Update System 2007-07-11 15:18:20 UTC
tclhttpd-3.5.1-14.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2007-07-17 16:47:04 UTC
tclhttpd-3.5.1-14.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.