Bug 242335 - RFE: Please update glib-java to version 0.4.2 or switch to java-gnome 4.0
RFE: Please update glib-java to version 0.4.2 or switch to java-gnome 4.0
Status: CLOSED DUPLICATE of bug 438452
Product: Fedora
Classification: Fedora
Component: glib-java (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Stepan Kasal
http://java-gnome.sourceforge.net/2.x/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 08:58 EDT by Marcin Garski
Modified: 2009-04-20 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 13:32:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Garski 2007-06-03 08:58:11 EDT
Hello,

Please read this first:
"glib-java 0.4.2 is part of the java-gnome 2.x family of libraries which had few
users and no mature applications built using them. As result, java-gnome 2.x
never made it to production quality and remains both buggy and incomplete. A
major re-engineering effort, termed java-gnome 4.0, is underway to produce an
entirely new set of Java bindings. The 2.x family as a whole has therefore been
declared deprecated pending imminent removal.

Those interested in using GTK and GNOME from Java are invited to join the
java-gnome hackers in their effort to bring the new 4.0 bindings up to speed.

Note to developers: As has been advertised for several release cycles now,
achieving an algorithmic mapping of the underlying GNOME libraries required a
significant ABI break from 2.x to 4.0. You are advised not to use the old
libraries for new projects.

Note to downstream packagers: There may or may not be a glib-java as a
individually released library in 4.0.  If there is, it may be called glib-java,
java-glib, but most likely will just be a .jar and .so build product from a
single module source release. For further details, see
http://java-gnome.sourceforge.net/

AfC
Maintainer
java-gnome"

As you can see java-gnome 2.x is deprecated. It would be great if you consider
switching to java-gnome 4.0 (http://java-gnome.sourceforge.net/4.0/). IMHO after
F7 release this is great time to break stuff in rawhide tree ;) But if this is
impossible at least update glib-java to version 0.4.2.

BTW If you choose update glib-java to version 0.4.2, there are others outdated
packages:
              Upstream Fedora
glib-java     0.4.2    0.2.6
cairo-java    1.0.8    1.0.5
libgtk-java   2.10.2   2.8.7
libgnome-java 2.12.7   2.12.4
libglade-java 2.12.8   2.12.5
libgconf-java 2.12.6   2.12.4
libvte-java   0.12.3   0.12.1

Should I then open similar bug reports in every component or this one is sufficient?
Comment 1 Danny D'Amours 2007-09-30 21:39:11 EDT
I suppose that it is too late to get this RFE included in time for F8?
Comment 2 Stepan Kasal 2007-11-08 06:19:59 EST
(In reply to comment #1)
> I suppose that it is too late to get this RFE included in time for F8?

Indeed, it was too late.  But the right time to bread F9 is right now.
I'll ask my coleagues about it.
Comment 3 Stepan Kasal 2007-11-09 11:20:38 EST
It i that the packages are not upgraded to the latest versions in the 2.x
branch; I'm going to folow your suggestion and upgrade soon, i.e., very early in
the F9 development.

But the java-gnome 4.0 is not yet as matured and stable as 2.x.

But the java-gnome 4.0 packages could be made available under a temporary name,
say glib-java-jg4 etc.  Would you be interested in this?
Comment 4 Andrew Cowie 2007-12-12 23:30:19 EST
(In reply to comment #3)
> But the java-gnome 4.0 is not yet as matured and stable as 2.x.

Ah. I see the misapprehension. Here's the thing: the 2.x series was never
stable. Why do you think we were forced to start all over again  18 months ago
and re-write the bindings from scratch?

> the java-gnome 4.0 packages could be made available under a temporary name,
> say glib-java-jg4 etc.  Would you be interested in this?

Well, you should be doing what every other distro is doing and what upstream
wants you to do, and that is call it "java-gnome". The current release is
java-gnome 4.0.5, 26 Nov 2007.

AfC
Comment 5 Jon Stanley 2008-04-23 16:29:30 EDT
Adding FutureFeature keyword to RFE's.
Comment 6 Drew Ogle 2009-01-06 08:51:52 EST
It's already past fedora 10.
Can someone look at switching over to 4.0 now?
Comment 7 Stepan Kasal 2009-04-20 13:32:31 EDT
java-gnome 4.x is going to be introduced as a new rpm, named java-gnome-4.x-*.rpm, as soon as the Review peocess is finished.
See the review, bug #438452, for details.

*** This bug has been marked as a duplicate of bug 438452 ***

Note You need to log in before you can comment on or make changes to this bug.