Bug 242351 - Error messages on PATA device with Intel Corporation 82801H
Error messages on PATA device with Intel Corporation 82801H
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 11:53 EDT by Florian Sievert
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 11:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of the affected system. Grep for "ata5". (36.35 KB, application/octet-stream)
2007-06-03 11:53 EDT, Florian Sievert
no flags Details
dmesg output of suddenly read-only mount of disk on the controller (3.62 KB, application/octet-stream)
2007-06-04 03:14 EDT, Florian Sievert
no flags Details

  None (edit)
Description Florian Sievert 2007-06-03 11:53:38 EDT
Description of problem:
During kernel startup, I am getting several error messages like:
 sde:<3>ata5.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2

The fifth device was formally a PATA drive working fine under FC6. The problem
was reproducible after a fresh installation of F7 on the same system.

The device is however available for the system and seems to be operational.
However the last days I encounter several times that the device was suddenly
mounted in read-only. I guess it might be a problem with the new PATA lib or the
controller itself.

The controller is a
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller (rev 02)
The hard disk is a
MODEL:              Maxtor 6Y120L0
FIRMWARE:           YAR41VW0

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3194.fc7

How reproducible:
Always

Steps to Reproduce:
1. Startup kernel with hardware described above.
  
Actual results:
Several lines with messages like:
sde:<3>ata5.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2
Possible random problems running a hard disk attached to the controller.

Expected results:
No error messages.

Additional info:
Mainboard is a Asus P5B using Intel Corporation 82801H (ICH8 Family). Logfile of
system startup is attached. Grep for "ata5". Please lead me in order to give
further informations.
Comment 1 Florian Sievert 2007-06-03 11:53:38 EDT
Created attachment 156025 [details]
dmesg output of the affected system. Grep for "ata5".
Comment 2 Florian Sievert 2007-06-04 03:14:52 EDT
Created attachment 156051 [details]
dmesg output of suddenly read-only mount of disk on the controller

Over night the hard disk was mounted as read-only again and I caught up the
output of dmesg. Looks basically identically for me like the messages on
startup. The disk can be used as ro without any problem, however when
dismounting (sucessfully) linux claims it is still in use. After a restart the
disk can be mounted without any problem.
Comment 3 Alan Cox 2007-06-05 13:53:42 EDT
Its recording repeated cable errors (ie data is being transferred and the
controller and drive checksums don't agree so they abort it). Could be cabling
but you say it works reliably with older releases ?
Comment 4 Florian Sievert 2007-06-06 11:06:29 EDT
I am quite confused now. I just checked with a second cable and without a DVD on
the bus and was able to reproduce the problem. Both cables was old long IDE
cables and I gave it a try with a new short one and the problem was gone. So it
might be pretty bad luck that two cables get broken exactly when updating to F7?
Could it be that the problem exist in FC6 but was not reported to me?

I guess it might be some bad luck and will close this bug.

Note You need to log in before you can comment on or make changes to this bug.