This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 242372 - libata incompatability causes installation faliure, old IDE system should be avaliable as a fallback because of this.
libata incompatability causes installation faliure, old IDE system should be ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 15:34 EDT by kentphilip
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 13:48:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kentphilip 2007-06-03 15:34:02 EDT
Description of problem:
My computer has a NVIDIA nForce 4 ATA controller in it. libata is incompatible 
with this controller, and causes faliures in the installation. The module 
loaded by Anaconda is ide_amd or similar.

Because of the experimental and problematic nature of the libata driver (it is 
marked as Raving Lunatic in the kernel config, and other experimental stuff), 
Fedora kernels should not use this by default, as it could cause hardware 
damage, and further issues. Old IDE system should be provided as a fallback 
(and respins done as needed to tackle with this serious issue).

Version-Release number of selected component (if applicable):
Stock Fedora 7 Kernel for i686.

How reproducible:
Always

Steps to Reproduce:
1. Boot Anaconda with affected system. VMware Server is one example.
2. Start the install

Note how Anaconda dies. Also note how the traditional IDE system is not used by 
default.
  
Actual results:
Anaconda dies, no method to go back to traditional IDE.

Expected results:
Traditional IDE is used by default, Anaconda does not die. User's hardware is 
in no risk of damage and enjoyment of Fedora can continue.

Additional info:
Comment 1 Dave Jones 2007-06-05 13:38:26 EDT
The 'raving lunatic' option is for something completely unrelated (SC1200).

The nforce should work. (and pata_amd being used for some nforce chipsets is normal)
Comment 2 kentphilip 2007-06-05 13:40:10 EDT
Ok. I noticed that the install crash is for something different, sorry to 
confuse, though I guess the install could crash if there is no libata IDE 
driver for the hardware.
Comment 3 Alan Cox 2007-06-05 13:48:43 EDT
pata_amd is pretty solid for Nvidia (has some cable detection glitches we know
about but those are also in the old driver).

And we don't ship any drivers that can destroy IDE hardware (nor with the
exception of one vendors bad CD screw up can you generally do that even
intentionally)

With no libata driver an install won't find the CD-ROM it booted off (or the
disks or whatever) but shouldn't crash. As libata supports more PCI and later
h/w than old IDE this shouldnt arise

Comment 4 kentphilip 2007-06-05 14:04:57 EDT
I feel regardless of this, the old IDE system should still be avaliable. But 
thanks for clearing this up.

Note You need to log in before you can comment on or make changes to this bug.