Bug 242374 - f-spot fails to start
Summary: f-spot fails to start
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: f-spot   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-03 19:47 UTC by Need Real Name
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 10:11:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2007-06-03 19:47:46 UTC
Description of problem:
f-spot will not start, when run it goes into a endless loop pushing out

Cant' get a connection to the dbus. Trying again...
Starting new FSpot server

My system is upgraded from FC6->F7T4 yum updated to F7 (yuck)

f-spot works for me on my work computer which was a F7T4 base install

Version-Release number of selected component (if applicable):
f-spot-0.3.5-2.fc7

How reproducible:
every time

Steps to Reproduce:
1.run f-spot
2.
3.
  
Actual results:

Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Starting new FSpot server
Cant' get a connection to the dbus. Trying again...
Expected results:


Additional info:

Comment 1 Christopher Aillon 2007-06-03 20:10:33 UTC
Silly question, but is dbus running?

Comment 2 Need Real Name 2007-06-03 20:22:42 UTC
Not silly at all, but it seems to be
[root@paris ~]# ps aux|grep dbus
dbus      2294  0.0  0.0   2956   984 ?        Ss   Jun03   0:02 dbus-daemon
--system
root      3931  0.0  0.0   2368  1072 ?        S    Jun03   0:00 /sbin/dhclient
-1 -lf /var/lib/dhclient/dhclient-eth0.leases -pf /var/run/dhclient-eth0.pid -q
-e dhc_dbus=31 -x -d eth0
stephen   4024  0.0  0.0   4484   520 ?        Ss   Jun03   0:00
/usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /etc/X11/xinit/Xclients
stephen   4027  0.0  0.0   2840   496 ?        S    Jun03   0:00
/usr/bin/dbus-launch --exit-with-session /etc/X11/xinit/Xclients
stephen   4028  0.0  0.0   2824   972 ?        Ss   Jun03   0:01
/bin/dbus-daemon --fork --print-pid 4 --print-address 8 --session
root     12912  0.0  0.0   4012   724 pts/2    R+   06:21   0:00 grep dbus


Comment 3 Christopher Aillon 2007-06-03 20:58:52 UTC
Wait, are you trying to run f-spot as root?

Comment 4 Need Real Name 2007-06-03 21:13:44 UTC
Nope, as myself. I am in the process of backing up my machine with a view to a
fresh install :(

Comment 5 Christopher Aillon 2007-06-03 22:23:57 UTC
I just tried on 3 machines: i686 fresh install of F7, i686 upgrade from F6 to
F7, and x86-64 fresh install of F7 and can't reproduce this.  :-(

Does moving your f-spot directory out of the way help?

cd $HOME/.gnome2
mv f-spot f-spot-backup

Comment 6 Need Real Name 2007-06-04 09:47:58 UTC
opens fine now after doing the mv command! Thanks a heap

Cheers

Comment 7 Christopher Aillon 2007-06-04 10:11:39 UTC
Oky, my guess is something got corrupted then in your profile.  Not sure what it
is.  You'll have to redo your tags I guess, so hopefully it's not that big of a
deal.  Closing this one.


Note You need to log in before you can comment on or make changes to this bug.