Bug 242378 - Will not send mail
Will not send mail
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 16:21 EDT by Janina Sajka
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 04:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
User mutt configuration -- inherited from years of use. (13 bytes, text/plain)
2007-06-06 11:22 EDT, Janina Sajka
no flags Details

  None (edit)
Description Janina Sajka 2007-06-03 16:21:51 EDT
Description of problem:
I've tried both 1.5.14-3 and 1.5.14-4 from updates on i386 and x86_64 via local console and ssh session.
On all three F-7 machines I've tried, mutt will not send mail. It returns 'bad idn' error, not liking my rednote.net domain. I've downversioned to the latest mutt from FC6 and all is OK.
Version-Release number of selected component (if applicable):1.5.14-X


How reproducible: Always


Steps to Reproduce:
1.Write an email
2.Attempt to send with 'y'
3.
  
Actual results:
bad idn

Expected results:
mail sent

Additional info:
Comment 1 Miroslav Lichvar 2007-06-05 06:56:59 EDT
I can't reproduce the problem.

Can you please attach here your mutt config? Also how is set the LANG or
LC_CTYPE environment variable?
Comment 2 Janina Sajka 2007-06-06 11:22:40 EDT
Created attachment 156364 [details]
User mutt configuration -- inherited from years of use.
Comment 3 Janina Sajka 2007-06-06 11:43:50 EDT
OK, since I see no way to upload my .muttrc via http using either lynx or elinks,
and since I won't be able to use Firefox at least until I can build FF3 (for accessibility reasons), I've made this file
available on my web server. Please retrieve it from:
http://rednote.net/.muttrc

Sorry for the inconvenience and for the empty attachment. This is new ground for me.
Comment 4 Miroslav Lichvar 2007-06-06 12:00:59 EDT
Thanks. The cause of the problem is this line:
set charset="mutt-utf-8"

Please comment it out or change it to "utf-8". Mutt in FC-6 didn't support IDN,
so it didn't try to convert encoding of the address.
Comment 5 Janina Sajka 2007-06-06 12:55:50 EDT
Yes, that was it. Thank you and sorry for the alarm here on Bugzilla.

Note You need to log in before you can comment on or make changes to this bug.