Bug 242387 - Kernel fails to recognise Sony CD-RW drive
Kernel fails to recognise Sony CD-RW drive
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 18:07 EDT by Chris Rankin
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 10:26:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from Jeff Garzik for libata (1.70 KB, patch)
2007-06-03 18:07 EDT, Chris Rankin
no flags Details | Diff

  None (edit)
Description Chris Rankin 2007-06-03 18:07:48 EDT
Description of problem:
ata_piix driver fails to initialise CDRW drive

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3194.fc7

How reproducible:
All the time.

Steps to Reproduce:
1. Boot.
  
Actual results:
scsi1 : ata_piix
ata2.00: ATAPI, max UDMA/33
ata2.01: ATAPI, max UDMA/33
ata2.00: configured for UDMA/33
ata2.01: qc timeout (cmd 0xef)
ata2.01: failed to set xfermode (err_mask=0x4)
ata2: failed to recover some devices, retrying in 5 secs
ata2.00: configured for UDMA/33
ata2.01: qc timeout (cmd 0xef)
ata2.01: failed to set xfermode (err_mask=0x4)
ata2.01: limiting speed to UDMA/33:PIO3
ata2: failed to recover some devices, retrying in 5 secs
ata2.00: configured for UDMA/33
ata2.01: qc timeout (cmd 0xef)
ata2.01: failed to set xfermode (err_mask=0x4)
ata2.01: disabled
ata2: failed to recover some devices, retrying in 5 secs
ata2.00: failed to set xfermode (err_mask=0x40)
ata2: failed to recover some devices, retrying in 5 secs
ata2.00: configured for UDMA/33
scsi 0:0:0:0: Direct-Access     ATA      IC35L090AVV207-0 V23O PQ: 0 ANSI: 5
SCSI device sda: 156250000 512-byte hdwr sectors (80000 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO 
or FUA
SCSI device sda: 156250000 512-byte hdwr sectors (80000 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO 
or FUA
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 >
sd 0:0:0:0: Attached scsi disk sda
scsi 1:0:0:0: CD-ROM            HL-DT-ST DVD-ROM GDR8162B 0015 PQ: 0 ANSI: 5


Expected results:
scsi 1:0:0:0: CD-ROM            HL-DT-ST DVD-ROM GDR8162B 0015 PQ: 0 ANSI: 5
scsi 1:0:1:0: CD-ROM            SONY     CD-RW  CRX216E   PD01 PQ: 0 ANSI: 5


Additional info:
The attached patch is only part of the 'always use polling SETXFER' patch that
Jeff Garzik referred me to. However, that patch must have been against
2.6.22-rc?? because it didn't apply cleanly. Fortunately, the bit that failed
was only for via-pata, so I've dropped that bit.
Comment 1 Chris Rankin 2007-06-03 18:07:48 EDT
Created attachment 156042 [details]
Patch from Jeff Garzik for libata
Comment 2 Dave Jones 2007-06-05 13:45:12 EDT
applied, thanks.
Comment 3 drago01 2007-06-05 16:37:14 EDT
this also should fix this one:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=234684

Note You need to log in before you can comment on or make changes to this bug.