Bug 242390 - [JAVA BLOCKER] CONFIG_ALLOC_RTSJ_MEM cannot be a module
[JAVA BLOCKER] CONFIG_ALLOC_RTSJ_MEM cannot be a module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.0
All Linux
low Severity urgent
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks: 242581
  Show dependency treegraph
 
Reported: 2007-06-03 19:21 EDT by IBM Bug Proxy
Modified: 2008-02-27 14:57 EST (History)
0 users

See Also:
Fixed In Version: 2.6.21-31.el5rt
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 12:22:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 35186 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-06-03 19:21:58 EDT
LTC Owner is: jstultz@us.ibm.com
LTC Originator is: jstultz@us.ibm.com


From Ted:
"Um, alloc_rtsj_mem must be compiled into the kernel.  That's because the RTSJ
TCK needs more space than the module can allocate using kmalloc().   So the
alloc_rtsj_mem driver must be compiled into kernel, so that it can allocate
memory out of the early_boot initialization, before the mm subsystem is
initialized. 

So CONFIG_RMEM can be 'm', but CONFIG_ALLOC_RTSJ_MEM must be 'y'. "

So this is a request that RH changes their -rt config to set
CONFIG_ALLOC_RTSJ_MEM to "y".
Comment 1 Tim Burke 2007-06-04 16:27:15 EDT
Please provide a description of the associated parameter describing mem size on
boot line.
Comment 2 IBM Bug Proxy 2007-06-04 18:01:01 EDT
----- Additional Comments From jstultz@us.ibm.com (prefers email at johnstul@us.ibm.com)  2007-06-04 17:57 EDT -------
If alloc_rtsj_mem is built statically, the boot option would be:
    alloc_rtsj_mem.size=<memsize>

Where an example size is 1024 
Comment 3 Tim Burke 2007-06-04 21:43:35 EDT
1024 what?  what is the units? pages? MB?
Comment 4 IBM Bug Proxy 2007-06-04 22:05:30 EDT
----- Additional Comments From jstultz@us.ibm.com (prefers email at johnstul@us.ibm.com)  2007-06-04 22:00 EDT -------
the size argument is in bytes. 
Comment 5 IBM Bug Proxy 2007-06-19 20:30:37 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|SUBMITTED                   |ACCEPTED




------- Additional Comments From jstultz@us.ibm.com (prefers email at johnstul@us.ibm.com)  2007-06-19 20:26 EDT -------
Verified fixed in 2.6.21-31.el5rt 

Note You need to log in before you can comment on or make changes to this bug.