Bug 242417 - Google Toolbar doesn't work without libstdc++.so.5
Summary: Google Toolbar doesn't work without libstdc++.so.5
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
low
urgent
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-04 08:57 UTC by Zhou Yunfei
Modified: 2018-04-11 18:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 06:28:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core dumped when Firefox installed with Google Toolbar exits (16.01 MB, application/x-gzip)
2007-06-05 01:16 UTC, Zhou Yunfei
no flags Details

Description Zhou Yunfei 2007-06-04 08:57:13 UTC
Description of problem:
incompatibility between firefox and Google Toolbar

Version-Release number of selected component (if applicable):
Fedora 7
Firefox 2

How reproducible:
Everytime

Steps to Reproduce:
1.Install Google Toolbar in preinstalled Firefox of Fedora 7
2.Login to Google
3.Press Bookmark button,no effect
4.Exit from Firebox,a core left
  
Actual results:
Google Toolbar ineffective
Firefox core dumped when exitting

Expected results:
As it happens

Additional info:

Comment 1 Zhou Yunfei 2007-06-04 08:59:01 UTC
There is no such occurrence in Ubuntu 7.04.

Comment 2 Matěj Cepl 2007-06-04 22:56:49 UTC
comment 1 is totally irrelevant -- Ubuntu has quite different browser. Could we
stay with Fedora, please?

Could you follow advice on
http://kb.mozillazine.org/Getting_a_stacktrace_with_gdb and provide us a
backtrace of when firefox crashes? Could you please attach it to this bug as
uncompressed attachment to this report please?

Thanks a lot

Comment 3 Zhou Yunfei 2007-06-05 01:16:34 UTC
Created attachment 156166 [details]
Core dumped when Firefox installed with Google Toolbar exits

Comment 4 Zhou Yunfei 2007-06-05 01:20:56 UTC
Irrelevant perhaps,but both Ubuntu 7.04 and Fedora 7 use Firefox 2 as default
web brower
A little help maybe.
That's the only case that I fail to use Google Toolbar in Firefox.

Comment 5 Zhou Yunfei 2007-06-05 01:23:30 UTC
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
Core was generated by `/usr/lib/firefox-2.0.0.3/firefox-bin -UILocale zh-CN'.
Program terminated with signal 11, Segmentation fault.
#0  0x00ae9402 in __kernel_vsyscall ()
(gdb) bt
#0  0x00ae9402 in __kernel_vsyscall ()
#1  0x00787071 in ?? ()
#2  0x0806637c in ?? ()
#3  0x0000000b in ?? ()
#4  0xbf951bd8 in ?? ()
#5  0x080596a2 in ?? ()
#6  0x0000000b in ?? ()
#7  0xbf951b4c in ?? ()
#8  0x00000000 in ?? ()


Comment 6 Christopher Aillon 2007-06-05 01:33:01 UTC
http://www.google.com/support/firefox/bin/answer.py?answer=53937

If you'd like to run the Google Toolbar for Firefox on a Linux platform, please
make sure your system has glibc 2.3.5 or higher and libstdc++5. You also need to
be running an x86 processor (PPC systems are not supported). Please note that
the Toolbar is currently unavailable for Fedora Core 6. We also recommend using
an official build of Mozilla Firefox from http://www.mozilla.org


% rpm -ql libstdc++       
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.8

I wonder if this is because that requires a waaayy much older libstdc++ than
what we ship...  Does the following command help?

yum install compat-libstdc++


Comment 7 Christopher Aillon 2007-06-05 01:52:23 UTC
Actually

yum install compat-libstdc++-33

Comment 8 Zhou Yunfei 2007-06-05 05:53:21 UTC
Thanks, it's done.
On FC6,I happened to installed compat-stdc++ beforehand,so everything is OK.
Fedora 7 is great,I'm so eager to taste Fedora 8!


Comment 9 Christopher Aillon 2007-06-05 06:28:10 UTC
Glad it works now.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.