Bug 242432 - Thunderbird segfaults when exiting
Thunderbird segfaults when exiting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
: Reopened
Depends On: 242155
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 06:28 EDT by Matteo Corti
Modified: 2008-02-29 09:27 EST (History)
1 user (show)

See Also:
Fixed In Version: nspr-4.6.7-0.7.1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 09:27:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace (7.12 KB, text/plain)
2007-06-12 08:21 EDT, Matteo Corti
no flags Details

  None (edit)
Description Matteo Corti 2007-06-04 06:28:04 EDT
Description of problem:
Thunderbird segfaults when exiting (only if started in the background)

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.0-1.fc7

How reproducible:
Thunderbird segfaults when exiting

Steps to Reproduce:
1. Open thunderbird (thunderbird &)
2. Close thunderbird
  
Actual results:
> thunderbird &
Segmentation fault      thunderbird

Expected results:
No segfault

Additional info:
> strace thunderbird &
[...]
close(48)                               = 0
futex(0xaa0dfe0, 0x5 /* FUTEX_??? */, 1) = 1
futex(0xa4927a0, FUTEX_WAKE, 1)         = 1
futex(0xa67942c, FUTEX_WAKE, 1)         = 1
futex(0xa679430, FUTEX_WAIT, 1, NULL)   = -1 EAGAIN (Resource temporarily
unavailable)
futex(0xa4927a0, FUTEX_WAKE, 1)         = 0
futex(0xabe3508, 0x5 /* FUTEX_??? */, 1) = 1
futex(0xa781868, FUTEX_WAKE, 1)         = 1
futex(0xa67942c, FUTEX_WAKE, 1)         = 1
futex(0xa679430, FUTEX_WAIT, 1, NULL)   = -1 EAGAIN (Resource temporarily
unavailable)
futex(0xa781868, FUTEX_WAKE, 1)         = 0
gettimeofday({1180952856, 57945}, NULL) = 0
write(14, "\372", 1)                    = 1
futex(0x9c2a570, 0x5 /* FUTEX_??? */, 1) = 1
munmap(0xb5ede000, 10489856)            = 0
close(53)                               = 0
munmap(0xb3eab000, 4096)                = 0
writev(30, [{"GIOP\1\2\1\5\0\0\0\0", 12}], 1) = 12
close(30)                               = 0
writev(28, [{"GIOP\1\2\1\5\0\0\0\0", 12}], 1) = 12
close(28)                               = 0
close(27)                               = 0
close(26)                               = 0
unlink("/tmp/orbit-corti/linc-4e08-0-29404a69966a6") = 0
close(29)                               = 0
exit_group(0)                           = ?
Process 19976 detached
[1]+  Done                    strace thunderbird
Comment 1 Matěj Cepl 2007-06-04 19:17:09 EDT
Could you please follow the information on
http://kb.mozillazine.org/Getting_a_stacktrace_with_gdb (the package you need to
install is firefox-debuginfo), and the please attach backtrace to this bug as a
separate uncompressed attachment.

Thanks,

matej
Comment 2 Matěj Cepl 2007-06-04 19:19:59 EDT
of course, it should be thunderbird-debuginfo rather than the firefox one.
Comment 3 Matteo Corti 2007-06-05 03:44:38 EDT
Hi,

I now have the following:

- my thunderbird script does not support the -g and -d options (?): I therefore
  edited it and added gdb to the exec line
- I get the gdb prompt
- I disable RT events
- I run it
- thunderbird starts but gdb crashes (?)

$ ./thunderbird
GNU gdb Red Hat Linux (6.6-8.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) handle SIG33 noprint nostop
Signal        Stop      Print   Pass to program Description
SIG33         No        No      Yes             Real-time event 33
(gdb) run
Starting program: /usr/lib/thunderbird-2.0.0.0/thunderbird-bin 
./thunderbird: line 58: 18975 Segmentation fault      gdb $MOZ_PROGRAM $MOZARGS
$ 

Trying with:
$ /usr/lib/thunderbird-2.0.0.0/run-mozilla.sh -g -d gdb
/usr/lib/thunderbird-2.0.0.0/thunderbird-bin
MOZILLA_FIVE_HOME=/usr/lib/thunderbird-2.0.0.0
 
LD_LIBRARY_PATH=/usr/lib/thunderbird-2.0.0.0:/usr/lib/thunderbird-2.0.0.0/plugins:/usr/lib/thunderbird-2.0.0.0:/home/corti/lib:
DISPLAY=:0.0
DYLD_LIBRARY_PATH=/usr/lib/thunderbird-2.0.0.0:/usr/lib/thunderbird-2.0.0.0
    
LIBRARY_PATH=/usr/lib/thunderbird-2.0.0.0:/usr/lib/thunderbird-2.0.0.0/components:/usr/lib/thunderbird-2.0.0.0:/home/corti/lib:
       SHLIB_PATH=/usr/lib/thunderbird-2.0.0.0:/usr/lib/thunderbird-2.0.0.0
          LIBPATH=/usr/lib/thunderbird-2.0.0.0:/usr/lib/thunderbird-2.0.0.0
       ADDON_PATH=/usr/lib/thunderbird-2.0.0.0
      MOZ_PROGRAM=/usr/lib/thunderbird-2.0.0.0/thunderbird-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=gdb
/usr/bin/gdb /usr/lib/thunderbird-2.0.0.0/thunderbird-bin -x /tmp/mozargs.K20313
GNU gdb Red Hat Linux (6.6-8.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) handle SIG33 noprint nostop
Signal        Stop      Print   Pass to program Description
SIG33         No        No      Yes             Real-time event 33
(gdb) run
Starting program: /usr/lib/thunderbird-2.0.0.0/thunderbird-bin 
/usr/lib/thunderbird-2.0.0.0/run-mozilla.sh: line 229: 20315 Segmentation fault
     $debugger "$prog" -x $tmpfile

Any idea on how I could get a backtrace?

Matteo
Comment 4 Matěj Cepl 2007-06-05 04:09:11 EDT
It is written in that mozillazine article mentioned above -- on gdb prompt
(after message about segmentation fault) type

backtrace

(but you also forgot to set  handle SIG33 noprint nostop before run command in
gdb; just recheck that article).

Output of backtrace just copy&paste to this bug as a comment (or if it is
longish, copy&paste to text file and attach that as an attachment to this bug).
Comment 5 Matteo Corti 2007-06-05 04:18:34 EDT
Hi,

> It is written in that mozillazine article mentioned above -- on gdb prompt
> (after message about segmentation fault) type

gdb crashes after running "run" -> I get the the shell prompt.

> (but you also forgot to set  handle SIG33 noprint nostop before run command in
> gdb; just recheck that article).

Not really:

[...]
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) handle SIG33 noprint nostop           <<<<<<<<<<<<< is there
Signal        Stop      Print   Pass to program Description
SIG33
[...]

Matteo
Comment 6 Christopher Aillon 2007-06-05 04:27:55 EDT
I wonder if this is the same as the NSPR threading bug...
Comment 7 Matěj Cepl 2007-06-05 04:35:35 EDT
From your output it seems to me that not gdb but thunderbird is crashing which
is expected. What happens when you run command bt in gdb prompt? Or is it really
gdb that crashes and you get back into bash (I cannot determine it from your
output)?
Comment 8 Matteo Corti 2007-06-05 04:39:08 EDT
It's gdb that crashes:
- thunderbird continues to run
- I get back to the shell

And BTW in this case thunderbird does not crash when I quit it (as it usually does)

Matteo
Comment 9 Jan Kratochvil 2007-06-05 05:00:22 EDT

*** This bug has been marked as a duplicate of 242155 ***
Comment 10 Matěj Cepl 2007-06-05 05:31:30 EDT
This is not correct, we don't want to sweep under the rug, that Thunderbird is
crashing as well ;-). On the other hand, I have no clue how to debug this bug,
when debugger crashes -- so making this bug dependent on bug 242155.
Comment 11 Christopher Aillon 2007-06-05 11:08:19 EDT
Probably related to bug 242370.
Comment 12 Matteo Corti 2007-06-12 08:21:45 EDT
Created attachment 156789 [details]
Stack trace

Since 242155 was closed I am now able to get a trace ...
Comment 13 Matteo Corti 2007-06-19 03:06:05 EDT
The bug is still present in thunderbird-2.0.0.4-1.fc7
Comment 14 Martin Stransky 2008-02-29 09:27:35 EST
Should be fixed by nspr-4.6.7-0.7.1.fc7.

Note You need to log in before you can comment on or make changes to this bug.