Bug 242470 - thunderbird refuses to start if not super-user
thunderbird refuses to start if not super-user
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 09:34 EDT by J.Jansen
Modified: 2008-02-29 09:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 09:25:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.Jansen 2007-06-04 09:34:48 EDT
Description of problem:
Trying to start thunderbird as "normal" user fails. It stops almost immidiately.
Switching to superuser and starting thunderbird works fine.

Version-Release number of selected component (if applicable):
2.0.0.0-1.fc7

How reproducible:


Steps to Reproduce:
1.upgarde to F7 and to the last version of thunderbird
2.start thunderbird as "normal" user
3.
  
Actual results:
stops almost immidiately

Expected results:
normal run and display

Additional info:
Comment 1 J.Jansen 2007-06-05 04:29:02 EDT
Changing the file protection of
/usr/thunderbird-2.0.0.0

(i.e. : chmod og+rx thunderbird-2.0.0.0 )

solved the problem

      Jouk
Comment 2 skerb1 2007-06-11 14:01:12 EDT
I think I have found part of the problem.  It looks like as a normal user we are
trying to open a file with write access in a place we should not even be trying to.

open("/usr/lib/thunderbird-2.0.0.0/components/xpti.dat.tmp",
O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = -1 EACCES (Permission denied)
brk(0x8ce7000)                          = 0x8ce7000
pipe([4, 5])                            = 0
fcntl64(4, F_GETFL)                     = 0 (flags O_RDONLY)
fcntl64(4, F_SETFL, O_RDONLY|O_NONBLOCK) = 0
fcntl64(5, F_GETFL)                     = 0x1 (flags O_WRONLY)
fcntl64(5, F_SETFL, O_WRONLY|O_NONBLOCK) = 0
read(4, 0xbffe04a3, 1)                  = -1 EAGAIN (Resource temporarily
unavailable)
close(4)                                = 0
close(5)                                = 0
brk(0x8cdf000)                          = 0x8cdf000
brk(0x8cde000)                          = 0x8cde000
brk(0x8cdd000)                          = 0x8cdd000
brk(0x8cdc000)                          = 0x8cdc000
brk(0x8cdb000)                          = 0x8cdb000
brk(0x8cda000)                          = 0x8cda000
brk(0x8cd9000)                          = 0x8cd9000
brk(0x8cd1000)                          = 0x8cd1000
brk(0x8cd0000)                          = 0x8cd0000
brk(0x8ccf000)                          = 0x8ccf000
brk(0x8cce000)                          = 0x8cce000
exit_group(1)                           = ?
Process 18260 detached
Comment 3 Christopher Aillon 2007-06-11 14:44:52 EDT
Does rpm -V thunderbird give any clues?  Did you run thunderbird as a superuser
before you ran it as a normal user?
Comment 4 J.Jansen 2007-06-12 02:56:57 EDT
aaee-jj ) rpm -V thunderbird
S.5....T   /usr/lib/thunderbird-2.0.0.0/components/xpti.dat
prelink: /usr/lib/thunderbird-2.0.0.0/thunderbird-bin: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/thunderbird-2.0.0.0/thunderbird-bin
prelink: /usr/lib/thunderbird-2.0.0.0/updater: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/thunderbird-2.0.0.0/updater
aaee-jj ) 



Thunderbird was just installed using Yumex and than started from the gnome-panel
of a "normal" user.

                  Jouk
Comment 5 skerb1 2007-06-12 03:40:27 EDT
[root@host1 ~]# whoami
root
[root@host1 ~]# rpm -V thunderbird
[root@host1 ~]#


<snip>
> whoami
user1
> thunderbird 
> echo $?
1

Works fine if I run as root.  I installed thunderbird with yum on fedora 7.  Ran
initially as root, then as normal user.
Comment 6 skerb1 2007-06-12 03:46:14 EDT
Also one thing to note is that it seems to work fine if i manually choose one of
my profiles:
thunderbird -P work

this works fine when I am a normal user.  The bug probably has something to do
with the ProfileManager code.
Comment 7 Christopher Aillon 2007-06-12 11:35:12 EDT
Maybe I need to add some code to prevent running as root.  It is a known issue
that if you run it as root the first time, subsequent runs will break for normal
users.

The workaround is to uninstall, and make sure the entire
/usr/lib/thunderbird-2.0.0.0/ directory is gone.  You might also need to remove
your user's $HOME/.thunderbird as well.
Comment 8 Christopher Aillon 2007-06-12 11:35:45 EDT
Oh and then re-install and run as a normal user first.
Comment 9 J.Jansen 2007-06-20 06:18:45 EDT
Same problem with 2.0.0.4.
I just upgraded with Yumex.
First run as "normal" user

        Jouk
Comment 10 J.Jansen 2007-07-23 06:01:37 EDT
2.0.0.5 same problem
Comment 11 J.Jansen 2007-11-13 07:03:23 EST
On a "fresh" installed F8 machine the problems seems not to occur.
Comment 12 Martin Stransky 2008-02-29 09:25:00 EST
cool, closing as rawhide.

Note You need to log in before you can comment on or make changes to this bug.