Bug 242472 - [pata_ali] libata / pata_ali doesn't work my old laptop PC
[pata_ali] libata / pata_ali doesn't work my old laptop PC
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 09:46 EDT by CHIKAMA Masaki
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 10:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output for F7 rescue cd booted on P2120 (16.00 KB, text/plain)
2007-06-06 02:48 EDT, TC
no flags Details
fdisk output for P2120 hard disk (710 bytes, text/plain)
2007-06-06 02:49 EDT, TC
no flags Details
dmesg output for F7 install on ext3 partition (16.00 KB, text/plain)
2007-06-06 22:58 EDT, TC
no flags Details
fdisk output for F7 on ext3 partition (783 bytes, text/plain)
2007-06-06 22:58 EDT, TC
no flags Details
fdisk output for F7 on ext3 partition (783 bytes, text/plain)
2007-06-06 23:19 EDT, TC
no flags Details
Fix rev C3/C4 UDMA speed limits (1.35 KB, patch)
2007-06-07 12:31 EDT, Alan Cox
no flags Details | Diff

  None (edit)
Description CHIKAMA Masaki 2007-06-04 09:46:46 EDT
Description of problem:
libata/pata_ali failed to find my IDE HDD.

Version-Release number of selected component (if applicable):
vmlinuz-2.6.21-1.3194.fc7

Additional info:
lspci said 
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c3) (prog-if a4)
        Flags: bus master, medium devsel, latency 64, IRQ 255
        I/O ports at 01f0 [size=8]
        I/O ports at 03f4 [size=1]
        I/O ports at 1810 [size=8]
        I/O ports at 1818 [size=4]
        I/O ports at 1800 [size=16]
        Capabilities: <access denied>

2.6.22-rc3 with rc3-mm1/drivers/ata/pata_ali.c works.
2.6.22-rc3 doesn't work.
Comment 1 Dave Jones 2007-06-05 13:51:05 EDT
alan, bits that need backporting to -stable ?
Comment 2 Alan Cox 2007-06-05 13:59:44 EDT
Can you provide the actual messages displayed when it fails, without them its
kind of hard to guess what is going on

(if need be switch to the console with the kernel message log on it and if it
looks relevant attach a digital photo of the screen)
Comment 3 CHIKAMA Masaki 2007-06-05 23:08:24 EDT
Here is boot message.

Uncompressing Linux ... Ok, booting the kernel.
Red Hat nash version 6.0.9 starting
ata1:00: cmd c8/00:08:08:00:00/00:00:00:00:00/e0 tag 0 cdb 0x0 data 4096 in
  Reading all physical volumes. This may take a while...
ata1:00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata1:00: cmd c8/00:18:00:00:00/00:00:00:00:00/e0 tag 0 cdb 0x0 data 12288 in
ata1:00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata1:00: cmd c8/00:08:80:3d:7e/00:00:00:00:00/e3 tag 0 cdb 0x0 data 4096 in
ata1:00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata1:00: cmd c8/00:08:00:00:00/00:00:00:00:00/e0 tag 0 cdb 0x0 data 4096 in
  No volume groups found
  Volume group "VolGroup00" not found


The 2nd and 3rd "ata1:00: cmd c8/00...." are differrent in each boot time.
Comment 4 TC 2007-06-06 01:17:29 EDT
I see something similar with my Fujitsu P2120 (Transmeta Crusoe) notebook as
well, which was previously running FC5.

The IDE Controller is ALi Corp M5229 IDE (rev c3) (prog-if fa)

F7 installation (custom partition) completed on my 2nd minimal installation
attempt (first installation attempt hung while installing OpenOffice.org), but
rebooting failed with kernel panic.

F7 Rescue CD was not able to detect the LVM partitions.

Currently I'm reinstalling as default linux partition which reformats the LVM
partition, as well as trying to figure out if it's related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=237415
Comment 5 TC 2007-06-06 01:52:17 EDT
Sorry, re Comment #4, I meant to refer to this:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241949
Comment 6 TC 2007-06-06 02:48:33 EDT
Created attachment 156322 [details]
dmesg output for F7 rescue cd booted on P2120

Just before rebooting from the F7 Install, I verified that all the LVM logical
volumes were mounted and looked correct.

Reboot fails to detect any Physical Volumes on the hard disk.

I'm seeing the following when booted using the F7 Rescue CD. The Volgroup
cannot be detected using lvm.
sh-3.2# lvm pvscan
  No matching physical volumes found
Comment 7 TC 2007-06-06 02:49:15 EDT
Created attachment 156323 [details]
fdisk output for P2120 hard disk

This is done using fdisk /dev/sda
Comment 8 Alan Cox 2007-06-06 09:53:55 EDT
0xC8 is a read command so thats a bit odd. Some minor fixes were done and I
guess you've got the device they actually matter to.

Are you in a position where you can build a few kernels so I can work out which
of the test patches in the -mm tree is making the difference ?
Comment 9 CHIKAMA Masaki 2007-06-06 11:16:17 EDT
(In reply to comment #8)
> Are you in a position where you can build a few kernels so I can work out which
> of the test patches in the -mm tree is making the difference ?

Yes. But there are some restriction.

1. This laptop has another bug. (#242474) 
So I have to rebuild with CONFIG_M486 when 2.6.22-rc1 and later.
2, This laptop's CPU is very slow. So I'll rebuild the kernel with another
machine (running with CentOS4.5/i386).

OK?
Comment 10 TC 2007-06-06 20:54:44 EDT
I have a FC5 x86_64 (Pentium D) system, as well as a Centos 4.4 i686 system I
can try to build kernels on. 

I've tried rebuilding the F7 kernel-2.6.21-1.3167.fc7.src.rpm SRPM within FC5 on
my P2120 previously but it had dependency issues (mkinitrd, which I couldn't
resolve easily so I just rpm --ivh --nodeps it, but it kernel panics on boot).
Comment 11 TC 2007-06-06 22:58:00 EDT
Created attachment 156418 [details]
dmesg output for F7 install on ext3 partition

I've tried reinstalling F7 on my P2120 using an ext3 partition (no LVM), and it
still fails on boot with the hard disk errors.

Again, the F7 Rescue CD can't locate any Fedora installation, and I can't mount
the parition from the shell.

sh-3.2# mount /dev/sda7 -t ext3 /mnt/sysimage
mount: Mounting /dev/sda7 on /mnt/sysimage failed: No such device or address

Strange, what's different between the F7 boot.img (I used HTTP install) and the
F7 Rescue CD?
Comment 12 TC 2007-06-06 22:58:39 EDT
Created attachment 156419 [details]
fdisk output for F7 on ext3 partition
Comment 13 TC 2007-06-06 23:19:07 EDT
Created attachment 156420 [details]
fdisk output for F7 on ext3 partition
Comment 14 Alan Cox 2007-06-07 12:31:29 EDT
Created attachment 156482 [details]
Fix rev C3/C4 UDMA speed limits

This should fix the problem on this box with luck
Comment 15 Chuck Ebbert 2007-06-07 15:59:42 EDT
patch from comment #14 is in CVS now. Will be in a kernel after 3219.
Comment 16 TC 2007-06-07 20:56:38 EDT
Comment on attachment 156420 [details]
fdisk output for F7 on ext3 partition

Duplicate post (browser refresh)
Comment 17 TC 2007-06-07 21:04:19 EDT
Is there anyway to override the IDE bus speed on the F7 installer boot prompt?
Otherwise I don't see any easy way to install F7 on my P2120 at this moment.
Comment 18 CHIKAMA Masaki 2007-06-07 22:15:48 EDT
(In reply to comment #14)
> Created an attachment (id=156482) [edit]
> Fix rev C3/C4 UDMA speed limits
> 
> This should fix the problem on this box with luck

Yes. 2.6.22-rc3 + the patch works fine so far.
Thank you.
Comment 19 CHIKAMA Masaki 2007-06-07 22:22:31 EDT
(In reply to comment #17)
How about upgrade from FC6 after fixed package is released ?
Or stay at FC6 for a while.
Comment 20 TC 2007-06-07 23:04:33 EDT
I had to do something like that for the FC5 release. The FC5 anaconda failed to
detect the Crusoe processor correctly and I had to reinstall FC4 then yum
upgrade to FC5. I was hoping to avoid it this time around, having skipped the
FC6 upgrade cycle.

I've tried booting the F7 kernel with ide=nodma. It does not have any effect on
the ata DMA configuration (F7 kernel still errors on HD access, resets to UDMA
100, then finally kernel panics).

What I don't understand is why the F7 installer can reset the DMA mode to 66 MHz
automatically and complete installation, whereas the F7 kernel can't be made to
do so on boot.

Using a FC4 rescue CD, I can mount the ext3 partitions and view the files. The
F7 rescue CD can't mount the partitions at all (I tried passing ide=nodma on the
F7 boot prompt to no effect).

If there's a way to upgrade the kernel rpm for the F7 install using an older FC
resuce disk, I'm willing to try it. This would be slightly less work than doing
the FC6->yum upgrade to F7 path.
Comment 21 CHIKAMA Masaki 2007-06-07 23:45:56 EDT
(In reply to comment #20)
>What I don't understand is why the F7 installer can reset the DMA mode to 66 MHz
>automatically and complete installation, whereas the F7 kernel can't be made to
>do so on boot.

I suppose installer wait for module load completion but nash doesn't.
Nash will go ahead before libata retry 3 times then down speed.
Comment 22 CHIKAMA Masaki 2007-06-08 00:21:44 EDT
(In reply to comment #21)
> Nash will go ahead before libata retry 3 times then down speed.

It seems to like so. In my initrd.img 

echo "Loading scsi_mod.ko module"
insmod /lib/scsi_mod.ko             <--- create /proc/scsi/scsi
echo "Loading sd_mod.ko module"
insmod /lib/sd_mod.ko
echo "Loading libata.ko module"
insmod /lib/libata.ko
echo "Loading ata_generic.ko module"
insmod /lib/ata_generic.ko
echo "Loading pata_ali.ko module"
insmod /lib/pata_ali.ko          <--- will retry 3 times, but...
echo Waiting for driver initialization.
stabilized --hash --interval 250 /proc/scsi/scsi <--- already created, so go ahead.
echo "Loading dm-mod.ko module"
insmod /lib/dm-mod.ko

This may be mkinitrd bug?
Comment 23 CHIKAMA Masaki 2007-06-08 01:00:09 EDT
(In reply to comment #22)
Sorry, I was wrong.

> insmod /lib/pata_ali.ko          <--- will retry 3 times, but...
> echo Waiting for driver initialization.
> stabilized --hash --interval 250 /proc/scsi/scsi <--- already created, so go
ahead.

This line proceed
 read /proc/scsi/scsi" 10 times with interval 250ms and all the data are same

Module load retry process doesn't end within 2.5sec, and start lvm volume
scanning then fail.
Comment 24 Hans de Goede 2007-06-10 07:29:45 EDT
There is an F7 kernel-update candidate available here:
http://people.redhat.com/davej/kernels/Fedora/fc7/RPMS.kernel/

Which amongst other things contains THE fix for this ALI IDE problem. Please try
this kernel and report back how it works for you.

Always be carefull when testing new kernels. Use rpm -ivh to install the new
kernel besides your current one so that you can always boot back into the old
kernel.
Comment 25 CHIKAMA Masaki 2007-06-10 23:51:55 EDT
(In reply to comment #24)

kernel-2.6.21-1.3226.fc7.i686.rpm
works fine with my laptop PC. Thank you.
Comment 26 TC 2007-06-11 21:26:42 EDT
I've managed to install kernel-2.6.21-1.3226.fc7.i686.rpm on my P2120 after
booting with an FC4 rescue CD. Subsequent reboot into F7 using this kernel works.

(I had to reinstall the kernel rpm via rpm -ivh --force due to the fact that
some post-install scripts were not able to execute correctly under FC4 rescue CD).

IDE is working properly on the P2120 now.
Comment 27 TC 2007-06-11 21:28:33 EDT
This issue should probably be added to the Fedora Install FAQ?

The way I solved it (short of a new F7 Install CD):
1. Install F7 using F7 installer
2. Use FCx rescue CD to install new kernel version
Comment 28 Chuck Ebbert 2007-06-12 13:13:54 EDT
(In reply to comment #27)
> This issue should probably be added to the Fedora Install FAQ?
> 
> The way I solved it (short of a new F7 Install CD):
> 1. Install F7 using F7 installer
> 2. Use FCx rescue CD to install new kernel version
> 

Please provide more details on how to use the rescue CD from an older release
to install a kernel on F7.

Comment 29 TC 2007-06-12 21:19:05 EDT
I used a FC4 Rescue CD which AFAIK didn't have /sys support.
I'm not sure if the FC5/6 Rescue CD would've been a better choice.

In any case,

1. Reboot using FCx Rescue CD, enabling Network, search and mount F7 partitions.
2. Copy the new kernel RPM onto the target system's /mnt/sysimage/root directory.
3. chroot /mnt/sysimage (I find this easier than to fiddle with rpm's options).
4. rpm -ivh <new kernel rpm>
5. Take note if there were warning messages during the postinstall phase.
6. Reboot into F7 (there may be some initscripts that indicate FAILED)
7. Reinstall kernel using rpm -ivh --force <new kernel rpm> if warnings were
present during step #5 & #6.
8. Reboot (at this point, the initscripts should run without any FAILED status)
Comment 30 Chuck Ebbert 2007-06-25 14:46:55 EDT
We need to push the patch upstream, it works but rawhide/F8 need it too.
So far it's not appeared upstream.

Note You need to log in before you can comment on or make changes to this bug.