Bug 242476 - Unhandled exception. GroupsError: No Groups Available in any repository
Summary: Unhandled exception. GroupsError: No Groups Available in any repository
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 7
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-04 14:01 UTC by Ian Chapman
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 14:55:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Chapman 2007-06-04 14:01:54 UTC
Description of problem:
After installing any software using Pirut, I get the following:

---

Component: Software Manager
Summary: TB5acb99f7 __init__.py:490:_getGroups:GroupsError: No Groups Available
in any repository

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 115, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 291, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 473, in
doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 517, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 490, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
repo: scmyumrepo-updates
reposWithGroups: []
self: <__main__.PackageManager object at 0x10541810>
e: requested datatype group not available
overwrite: False

----------------

It's using a local repo file pointing to a local mirror. The error may indeed be
correct but I feel it should handle it gracefully.


As a side-note, pirut says:

"An unhandled exception has occurred... <snip> file a detailed report
against _Software Manager_ at https://bugzilla.redhat.com/bugzilla"

This seems a little misleading to me because AFAIK there's no component called
Software Manager in BZ. Perhaps saying "file agains pirut" would be more accurate.



Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7


How reproducible:
Load Pirut. Install any software.


Steps to Reproduce:
1. Load Software Manager
2. Install some software
3. Unhandled exception warning then quits.
  
Actual results:

Unhandled exception

Expected results:

The exception should be handled... I guess.

Additional info:

Comment 1 Jeremy Katz 2007-06-04 20:12:41 UTC
What version of yum do you have installed?

Comment 2 Ian Chapman 2007-06-04 20:43:19 UTC
yum-3.2.0-1

As a jic, the arch is ppc64 even though yum and pirut are noarch.

Comment 3 Jeremy Katz 2007-06-05 14:55:07 UTC
Okay, I think I see the case I missed.  Will be fixed in pirut-1.3.8 which I'll
push to rawhide and then likely as an F7 update a little bit after.

Comment 4 Ian Chapman 2007-06-05 21:12:23 UTC
Thanks very much.


Note You need to log in before you can comment on or make changes to this bug.