Bug 242480 - python-crypto fails to build on ppc64
python-crypto fails to build on ppc64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-crypto (Show other bugs)
7
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64
  Show dependency treegraph
 
Reported: 2007-06-04 10:15 EDT by Paul Howarth
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1-7.1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 17:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2007-06-04 10:15:46 EDT
Full build log available here:
http://people.redhat.com/notting/ppc64-rebuild/python-crypto-2.0.1-7/build.log

Problem appears to be that site-packages/Crypto/PublicKey/_fastmath.so is not
created, and this is probably due to setup.py not finding the GMP library. I
speculate (not having a ppc64 box) that the existing patch for x86_64 would also
fix ppc64 if applied.

The absence of python-crypto from the F7 ppc64 repository is causing dependency
problems for bittorrent, which requires it.
Comment 1 David Woodhouse 2007-06-04 10:26:30 EDT
Yes, that patch seems to have been the wrong way to handle it from the start.
Perhaps something like the following, instead of applying that patch:

sed -i s:/lib:/%_lib:g setup.py
Comment 2 David Woodhouse 2007-06-04 11:25:40 EDT
Committed and built in rawhide. Could probably do with a F-7 build but I'll
leave that to package maintainer, along with questions about whether to add a
disttag, etc.
Comment 3 Fedora Update System 2007-06-13 17:05:27 EDT
python-crypto-2.0.1-7.1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.