Bug 242485 - SnapScan1212U doesn't work
SnapScan1212U doesn't work
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-06-04 10:41 EDT by Matthias Bachert
Modified: 2008-01-10 12:06 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-08 20:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthias Bachert 2007-06-04 10:41:56 EDT
Description of problem:
If I start xsane I get an error message saying: "Failed to start scanner. Error
on device I/O"

Firmware is properly set up in snapscan.conf

It works in SuSE 10.2 however.
Comment 1 Frode Tennebø 2007-06-12 17:38:48 EDT
I have the same scanner, and the exact same error.  However, I can make a 
preview or a scan once.  On the return the array stops about 1/4 way bac, i.e. 
3/4 from the "start position".  If I now try to scan/preview a second time, the 
scanner omits a rather discouraging bzzzzz-sound, but stays put.  Then the 
sound stops and the light goes out.

I can re-set the scanner by pulling the power and I can perform the exact same 
procedure once more....

It worked with FC6 before I upgraded to F7.
Comment 2 Frode Tennebø 2007-06-12 17:39:52 EDT
Oh...I get the error after the second time when the light goes out/sound stops.
Comment 3 Nils Philippsen 2007-06-13 04:55:12 EDT
lease get the latest FC6 kernel:


Install it ("rpm -ivh --oldpackage ..."), reboot into that kernel and report
back whether this makes a difference.

If the latest kernel of FC6 doesn't work, please try the first FC6 kernel as well:

Comment 4 Frode Tennebø 2007-06-13 15:04:48 EDT
I tried this one which I already had installed and it works like a charm.  Let 
me know if you need to test the newer FC6 one.

[ft@luke ~]$ uname -a
Linux luke 2.6.20-1.2948.fc6 #1 SMP Fri Apr 27 19:48:40 EDT 2007 i686 i686 i386 
Comment 5 Nils Philippsen 2007-06-14 03:18:05 EDT
It seems that "something" in the kernel's USB subsystem has changed between the
FC6 kernel that works and the F7 one that doesn't which renders your scanner not
working. I'll change the component to "kernel", so the kernel maintainers can
investigate further, i.e. whether the bug is in the kernel or changes in it only
revealed an up to now hidden bug in userspace.

I guess the kernel maintainers will tell you whether you should try the latest
FC6 kernel as well.
Comment 6 Christopher Brown 2007-09-13 16:24:23 EDT
Hello folks,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.


I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Comment 7 Christopher Brown 2008-01-08 20:02:50 EST
As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.
Comment 8 Frode Tennebø 2008-01-10 12:01:55 EST
Sorry for not reporting back.  Somehow I have missed the previous notice.  I can
confirm that after a few weeks with the FC6 kernel, a new F7 kernel arrived
which solved this case.  Can't remember the version.  Sorry.

Note You need to log in before you can comment on or make changes to this bug.