Bug 242507 - Can't build driver update model packages.
Can't build driver update model packages.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-rpm-config (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 12:11 EDT by Gerd Hoffmann
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-21 22:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
src rpm (1.35 MB, application/octet-stream)
2007-06-04 12:11 EDT, Gerd Hoffmann
no flags Details

  None (edit)
Description Gerd Hoffmann 2007-06-04 12:11:42 EDT
Description of problem:
Can't build driver update model packages

Version-Release number of selected component (if applicable):
redhat-rpm-config-8.0.45-17.0.1.el5

How reproducible:
Try building the attached source rpm.
brew build --scratch dist-5E xenpv-3.1_15040-0.src.rpm

Actual results:
Build fails, complaining about build dependencies not being satisfied.

Expected results:
Build works.

Additional info:
Local build fails on i386 too, with a slightly different error message.
Local build on x86_64 works (this is how the source rpm was created).
Comment 1 Gerd Hoffmann 2007-06-04 12:11:42 EDT
Created attachment 156092 [details]
src rpm
Comment 2 Gerd Hoffmann 2007-06-04 12:15:51 EDT
brew error message:

Executing /usr/sbin/mock-helper chroot
/var/lib/mock/dist-5E-build-255119-51671/root /sbin/runuser - root -c
"/sbin/runuser -c 'rpmbuild -bs --target ia64 --nodeps
/builddir/build/SPECS/xenpv.spec' brewbuilder"
Building target platforms: ia64
Building for target ia64
Wrote: /builddir/build/SRPMS/xenpv-3.1_15040-0.src.rpm
Executing /usr/sbin/mock-helper yum --installroot
/var/lib/mock/dist-5E-build-255119-51671/root resolvedep  'kernel-devel-ia64 =
package' 'kernel-devel'
No Package Found for kernel-devel-ia64 = package
0:kernel-devel-2.6.18-8.1.4.el5.ia64
Cleaning up...
Comment 3 Gerd Hoffmann 2007-06-04 12:17:10 EDT
local build on i386:

error: Failed build dependencies:
        kernel-devel-i386 = 2.6.18-20.el5.kraxel.3 is needed by
xenpv-3.1_15040-0.i386
Building target platforms: i686-linux
Building for target i686-linux

rhel5 kraxel ~/packages/xenpv# rpm -q --provides kernel-devel
kernel-devel-i686 = 2.6.18-20.el5.kraxel.2
kernel-devel = 2.6.18-20.el5.kraxel.2
kernel-devel-i686 = 2.6.18-20.el5.kraxel.3
kernel-devel = 2.6.18-20.el5.kraxel.3
Comment 4 Gerd Hoffmann 2007-07-04 06:18:45 EDT
local build using mock fails too, due to the same strange dependency
("kernel-devel-%{_target_cpu} = package" instead of "kernel-devel-%{_target_cpu}
= kernelversion"), looks like mock is the culpit here.
Comment 5 Gerd Hoffmann 2007-07-10 06:46:40 EDT
Uhm, mock fails to resolve build dependencies due to some trickery in
/usr/lib/rpm/redhat/macros which works only with kernel-devel being installed. 
kernel-devel isn't part of the buildsys-build build dependencies -> Oops.
Comment 7 Jon Masters 2007-08-20 03:16:08 EDT
Closing as this is not actually a bug in the driver update program, but a "bug"
in ensuring the right packages are installed and that the build is for the
appropriate target (i686 not i386).

Jon.
Comment 8 Gerd Hoffmann 2007-08-20 04:17:46 EDT
Having kernel-devel installed works for local builds.
As explained in comment #5 it doesn't work with mock and thus also fails for
brew/koji builds -> reopening bug.

Obvious trivial fix would be to add a "Requires: kernel-devel" to the
buildsys-build package.  But that has the drawback to pull in the kernel-devel
package for each and every package build.
Comment 9 Jon Masters 2007-08-23 22:37:57 EDT
Er...it doesn't fail for brew builds because we do them all the time! Hmmm...I'm
wondering what's up here.

Jon.

Note You need to log in before you can comment on or make changes to this bug.