This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 242529 - gstreamer manpage file conflict
gstreamer manpage file conflict
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 14:04 EDT by Andrig T Miller
Modified: 2013-01-09 23:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 15:39:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrig T Miller 2007-06-04 14:04:49 EDT
Description of problem:

The new pidgin packages, which replace the old GAIM packages will not install. 
It fails with a file conflict in the gstreamer package man page file.  It is
adding that as a dependency when it is already installed on my system, and that
causes the file conflict.

It adds all the following dependencies:

NetworkManager-glib-0.6.4-5.fc6
evolution-data-server-1.8.3-6.fc6
gstreamer-0.10.11-1.fc6
gtkspell-2.0.11-2.1
libpurple-2.0.1-1.fc6
libpurple-2.0.1-1.fc6
libsilc-1.0.2-2.fc6
libsoup-2.2.99-1.fc6
meanwhile-1.0.2-3.fc6
meanwhile-1.0.2-3.fc6
startup-notification-0.8-4.1

Of which only libpurple and meanwhile are not already installed on my system and
at the correct version.  Therefore, the gstreamer issue is only the first file
conflict, there are many more that would occur trying to install this package.


Version-Release number of selected component (if applicable):

2.0.1

How reproducible:

Everytime.


Steps to Reproduce:
1. View updates from yum tray icon.
2. Select pigdin package.
3. Select apply updates.
  
Actual results:

Adds the above mentioned dependencies, and then when trying to install gets file
conflict errors because the dependency list is incorrect.

Expected results:

Should have added the meanwhile and libpurple dependencies only, and installed
cleanly.

Additional info:
Comment 1 Mark Doliner 2007-06-04 14:20:12 EDT
I wonder if you're trying to install an i386 rpm on an x64_64 system, or vice-versa?
Comment 2 Stu Tomlinson 2007-06-04 14:24:19 EDT
If you select all available updates instead of just Pidgin does this work?
Comment 3 Andrig T Miller 2007-06-04 15:00:10 EDT
I only have the 64-bit version of GAIM installed, and the update should be for
that, so I don't think it would pick the 32-bit version when I am using the tray
icon interface for yum.

In regards to selecting all available updates that is what I did first, and it
still didn't work.  In fact, to figure out what was causing it, I deselected one
update at a time to figure out that it was Pigdin that was causing the problem.
 All the other updates applied fine, and the only update left in the interface
is Pigdin.
Comment 4 Jesse Keating 2007-06-04 15:39:11 EDT
Can you please list which specific file conflict you got?
Comment 5 Andrig T Miller 2007-06-04 15:57:36 EDT
Here is the specific conflict:

[('file /usr/share/man/man1/gst-launch-0.10.1.gz from install of
gstreamer-0.10.11-1.fc6 conflicts with file from package
gstreamer-0.10.11-1.fc6', (7, '/usr/share/man/man1/gst-launch-0.10.1.gz', 0L))]

Of course, as I was trying to point out, that this is merely the first conflict
of many, since it is trying to install packages, via added dependencies, that
are already installed.

Of the dependencies added (listed in the body of the report) only meanwhile and
libpurple are not already installed and at the correct version.
Comment 6 Andrig T Miller 2007-06-04 16:11:57 EDT
So, I tried something, and what do you know it worked.  Instead of clicking on
the yum updatesd tray icon and selecting "View updates", I started up the
Package Manager application, searched for pidgin, and selected it to install. 
It added only the libpurple and meanwhile dependencies, and it installed
perfectly.  After that, when I "View updates" through the tray icon (PUP), I get
no updates available.  Don't know why PUP is adding all the extra dependencies,
so this looks  like a PUP issue and not a package issue.
Comment 7 Jesse Keating 2007-06-04 16:13:29 EDT
This is due to multilib.  It's trying to bring in the gstreamer.i386 package
when you already have gstreamer.x86_64, and there seems to be a conflict in the
package that is a separate bug/problem.  We're still investigating on a test
install.
Comment 8 Warren Togami 2007-06-04 16:24:13 EDT
> Of course, as I was trying to point out, that this is merely the first conflict
> of many, since it is trying to install packages, via added dependencies, that
> are already installed.

Please don't confuse the issue.  gstreamer is the only confirmed conflict so far.

Reproduce Procedure:
1) Install only gaim.x86_64 and gstreamer.x86_64.
2) yum update and say yes.  It will pull in gstreamer.i386.

Update fails with:
Transaction Check Error:   file /usr/share/man/man1/gst-launch-0.10.1.gz from in
stall of gstreamer-0.10.11-1.fc6 conflicts with file from package gstreamer-0.10
.11-1.fc6   

Comment 9 josip 2007-07-04 22:08:51 EDT
I had the same problem: gstreamer.i386 gets pulled in to satisfy dependencies
even though the machine is x86_64, then yum -y update fails because of a man
page conflict between i386 and x86_64 versions of gstreamer.

Until gstreamer RPMs are rebuilt to fix this non-problem, here is a workaround
(assuming that gstreamer-0.10.11-1.fc6.x86_64.rpm is already installed):

rpm -ivh --force gstreamer-0.10.11-1.fc6.i386.rpm
yum -y update

This worked on my system.
Comment 10 Bug Zapper 2008-04-04 03:22:11 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 Bug Zapper 2008-05-06 15:39:49 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.