Bug 242546 - Cannot open/read repomd.xml file for repository: anaconda-base-200705271038.i386
Cannot open/read repomd.xml file for repository: anaconda-base-200705271038.i386
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Sivák
Depends On: 242766
  Show dependency treegraph
Reported: 2007-06-04 15:15 EDT by Andre Robatino
Modified: 2008-06-16 21:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
freshrpms.repo (354 bytes, application/octet-stream)
2007-06-09 08:52 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Andre Robatino 2007-06-04 15:15:09 EDT
Description of problem:

  When attempting a graphical F7 install, it said that due to low memory (I have
256 MB), it had to enable swap immediately, so it would have to write the
partition table immediately.  After agreeing, it did this, then failed with an
Error message:

"Unable to read package metadata.  This may be due to a missing repodata
directory.  Please ensure that your install tree has been correctly generated. 
Cannot open/read repomd.xml file for repository: anaconda-base-200705271038.i386"

  Someone on fedora-list had a similar problem:


Version-Release number of selected component (if applicable):

How reproducible:
not sure

Steps to Reproduce:
1. attempt clean install from F7 DVD

Additional info:

  Prior to this I had attempted the same type of install with a different HD in
the same machine.  In that case, the HD wasn't even detected.  I subsequently
did a successful install using the FC6 CD set which was able to detect said HD
properly.  I verified all media with mediacheck and by reading the ISO directly
off the burned disc and checking its sha1sum before use.
Comment 1 Jeremy Katz 2007-06-04 16:21:55 EDT
What type of installation were you doing?  Was it a network install?  If so,
what network repo were you pointing at?
Comment 2 Andre Robatino 2007-06-04 16:25:05 EDT
  It was a local clean install from the F7 DVD.  I didn't choose any packages
from external repos.
Comment 3 Andre Robatino 2007-06-04 16:34:06 EDT
  If there are any logfiles created up to the point of the error message that
would be of use, I can duplicate the problem by swapping in the hard drive I was
using when the problem happened (which has had its partition tables hosed
anyway), and attempting the install again.  Let me know.
Comment 4 redtux 2007-06-07 07:38:30 EDT
Dont know if will help - but you could try upping swap to around 500-750M
Comment 5 Andre Robatino 2007-06-07 19:09:07 EDT
  I didn't check but since the box has 256M RAM it probably assigns 512M swap by
Comment 6 John Dennis 2007-06-08 14:29:41 EDT
I'm not sure if this is related or not but one of my F7 UPGRADES failed part way
though apparently due to lack of memory. Peter Jones came by my cube and
determined that the available swap partitition had not been mounted and there
was no swap space. Peter manually mounted the swap partition at the start of the
install and it seem to procede although I didn't let it run to completition
because I later decided a clean install was preferred to an upgrade on this box
and killed it.

It appears an upgrade does not properly handle the partitions in some manner,
specifically it fails to find and mount swap. This seems to be an issue because
upgrades seem to consume much more virtual memory than does an install.
Comment 7 Leslie Satenstein 2007-06-08 14:37:18 EDT
========= similar message with freshrpms ====================
Can someone please explain this message
yum under root complains that it

Cannot open/read repodata/repomd.xml file for repository: freshrpms

-rw-r--r-- 1 root root   2142 2007-06-07 12:43 repomd.xml

On my 64 bit system, it works just fine....

Regarding Swap size, I have it set to double the amount of real memory.
My system -- 1 gig memory, 2gig swap, Fc7 32 bit.

Fc7 64 bit works just fine.

==========  repro livna works fine ==================

Comment 8 Leslie Satenstein 2007-06-08 15:03:29 EDT
I am investigating why  

yum --noplugins  works. 

How to determine which plug-in is causing the problem with the 32 bit version?

Need to know where the plug-ins are stored and the parameter file for same.
Comment 9 Leslie Satenstein 2007-06-09 08:50:54 EDT
Determined the problem is possibly in the yum parser. (32 bit fc7).

The following does not work

# $Id: freshrpms.repo 3341 2005-06-28 18:40:26Z thias $
name=Fedora Core $releasever - $basearch - Freshrpms

but eliminating the # at the baseurl1 resolved the problem.

The same unchanged repo file works just fine in 64 bit mode.
Comment 10 Leslie Satenstein 2007-06-09 08:52:19 EDT
Created attachment 156646 [details]

The actual raw input from freshrpms.net
Comment 11 Andre Robatino 2007-06-09 17:45:01 EDT
  My father is currently doing a clean offline install from the F7 DVD on
essentially the same machine as mine - same motherboard, different CPU and hard
drive.  His 20 GB drive was properly detected, he got the same low memory
warning as me (both of our machines have 256 MB RAM), but in his case the
installer completed this phase successfully.  So the low memory message doesn't
seem related to the bug.
Comment 12 Martin Sivák 2007-09-24 04:29:21 EDT
(In reply to comment #7)
> ========= similar message with freshrpms ====================

Please next time fill another bug, because the message is similar, but the
situation is very different. It could be misconfigured repo on the freshrpms side.
Comment 13 Martin Sivák 2007-09-24 04:32:00 EDT
Andre Robatino:
Can you please provide details about hardware in the machine? (harddrives,
ide/scsi/sata controller, chipset etc.).

Comment 14 Andre Robatino 2007-09-24 04:38:50 EDT
  With the exception of the HD, the hardware is the same as that associated with
my attachments to bug #242766.  The 8.6 GB HD that was installed when I had this
bug is a Seagate ST38422A.  After buying the 120 GB HD, I'm not anxious to put
the smaller drive back.  Let me know if this is enough info.
Comment 15 Martin Sivák 2007-09-24 05:01:01 EDT
It is enough, but unfortunately it seems to be very closely related to your
harddrive detection problems in the mentioned bug. I'll add a dependency on it
and watch it some more, but there is very little I can do right now except to
wait for kernel guys response.
Comment 16 Martin Sivák 2008-02-27 08:01:30 EST
Andre: I noticed you solved/workarounded the situation in the #242766. Was this
bug solved also by correcting the jumper selection?
Comment 17 Andre Robatino 2008-02-27 08:16:06 EST
  I experienced this bug while a different, smaller, HDD was installed in the
machine (see "Additional info" above).  The F7 installer never had any problem
detecting that drive.  Since I currently have a working F6 installation using
the bigger HDD, and since F9 is coming out in about 2 months, I don't plan on
attempting another install with the current drive until then - this is just a
backup machine and it's unlikely I'll have to use it before then.  So I won't
know until then whether the bug exists using the current HDD.
Comment 18 Bug Zapper 2008-05-14 08:47:53 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Bug Zapper 2008-06-16 21:24:42 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.