Bug 242560 - Gdk-ERROR **: error while retrieving Xinerama information
Gdk-ERROR **: error while retrieving Xinerama information
Status: CLOSED DUPLICATE of bug 234567
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2007-06-04 16:08 EDT by Brendan Mchugh
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-05 09:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg.conf (801 bytes, application/octet-stream)
2007-06-04 16:28 EDT, Brendan Mchugh
no flags Details
Xorg.0.log (93.04 KB, application/octet-stream)
2007-06-04 16:29 EDT, Brendan Mchugh
no flags Details

  None (edit)
Description Brendan Mchugh 2007-06-04 16:08:33 EDT
Description of problem:

gtk2 apps SIGABRT because of some xinerama detection error in gdk or xserver.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot to runlevel 3
2. run xinit
3. run any gtk2 app (gdm, gedit, gnome-terminal)
Actual results:

Gdk-ERROR **: error while retrieving Xinerama information

Expected results:

gtk2 app should run

Additional info:

PC: Fujitsu Siemens Amilo Xi 1554 (ati mobility radeon X1900)
Working on same hardware: Fedora Core 6, CentOS 5, Debian Etch.

The problem started with gdm crashing after fresh install of f7, so i changed to
vt1, logged in and ran telinit 3. I then run xinit and X works at 1600x1200 with
vesa driver. Running twm and xterm is ok. Running anything gtk2 based such as
gdm, system-config-* causes the error above.

I have tried Option "Xinerama" "off" in xorg.conf, but xorg.0.log still reports
Initializing built-in extension XINERAMA so i am not sure the setting is working
as i would expext.
Comment 1 Brendan Mchugh 2007-06-04 16:28:18 EDT
Created attachment 156127 [details]
Comment 2 Brendan Mchugh 2007-06-04 16:29:43 EDT
Created attachment 156128 [details]
Comment 3 Brendan Mchugh 2007-06-04 16:36:21 EDT
rpms are all from i386 dvd release with no updates

Comment 4 Adam Jackson 2007-06-05 09:41:47 EDT

*** This bug has been marked as a duplicate of 234567 ***

Note You need to log in before you can comment on or make changes to this bug.