Bug 242576 - When installing via network using usb key grub is not configured properly
When installing via network using usb key grub is not configured properly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: booty (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 17:13 EDT by Alastair Neil
Modified: 2008-06-16 21:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alastair Neil 2007-06-04 17:13:23 EDT
Description of problem:
Boot from a usb key and perform network install
Install Fedora 7
reboot fails as which boot sector out of range 

Version-Release number of selected component (if applicable):


How reproducible:
Tried twice on two different Dell systems same result

Steps to Reproduce:
1. Tell anaconda to ignore the loopback file system on the usb key (twice! why?)
2. Un-check the sdb drive in the disk target selection page
3. Specifically select the internal disk as the desired boot disk (usb key still
listed as default even though it's been unchecked why?)
4. Install
5. Reboot

  
Actual results:
reboot fails with boot sector out of range

Expected results:
Fedora niceness

Additional info:
booting from the USB key now boots the system properly.
device map lists 

(hd1) /dev/sda
(hd0) /dev/sdb

grub.conf
references (hd1,0) for the boot partition.

I suspect that this drive ordering is being changed by the BIOS so that the
internal drive is only hd1 when booting from the usb thumbdrive.

changing the hd1 to hd0 in device.map and grub.conf and running grub-install
/dev/sda fixes the issue.
Comment 1 Bug Zapper 2008-05-14 08:48:40 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2008-06-16 21:25:20 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.