Bug 242580 - Nouveau driver error: nouveau_dri.so not found
Summary: Nouveau driver error: nouveau_dri.so not found
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-04 21:47 UTC by Fdor
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 17:05:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fdor 2007-06-04 21:47:30 UTC
Description of problem:

I was using nv driver in fc6. After upgrading from fc6 to f7, I wanted to try
nouveau driver (which supports direct redering, beryl, etc), so I renamed my
xorg.conf to xorg.conf.oldd, run "Xorg -configure", edited the new xorg.conf
file to add my old Modeline to the monitor section and my old resolution to the
Display subsection, and finally rebooted the X server.

The result is that it works slowly (slower than with nv driver). And it's
probably due to a missing file: 

        ...
        drmOpenByBusid: drmOpenMinor returns 9
        drmOpenByBusid: drmGetBusid reports pci:0000:00:05.0
     >  (EE) AIGLX error: dlopen of /usr/lib/dri/nouveau_dri.so 
     >       failed (/usr/lib/dri/nouveau_dri.so: cannot open 
     >       shared object file: No such file or directory)
        (EE) AIGLX: reverting to software rendering
        (II) Loading local sub module "GLcore"
        (II) LoadModule: "GLcore"
        ...

As you can see, nouveau_dri.so is not found in /usr/lib/dri. This directory is
owned by mesa-libGL-6.5.2-10.fc7 package, which provides many *_dri.so files,
but not nouveau_dri.so.

Do I have to install some other rpm to add that file and get nouveau working?
I've done a quick search in the internet, and apparently nouveau_dri.so has been
added to the mesa package in 6.5.3 version. If that is correct, then please
recompile the new version and put the new mesa binaries in the repositories to
update.





Version-Release number of selected component (if applicable):

  mesa-libGL-6.5.2-10.fc7

How reproducible:

  Always

Steps to Reproduce:
  1. Upgrade fc6 to f7
  2. Rename xorg.conf
  3. Run:  Xorg -configure
  4. Add your modeline and resolution to the xorg.conf file.
  5. Reboot the X server.
  
Actual results:

  X very slow (slower than with nv driver)

Expected results:

  Faster than nv driver (because of direct redering)

Additional info:

- Last available updates applied ("yum update").

- Bug on bugzilla ;) : There is no "xorg-x11-drv-nouveau" component in the bug
description (so I've choosen "xorg-x11-drivers").

Comment 1 Adam Jackson 2007-06-06 22:29:19 UTC
The nouveau DRI driver is intentionally not packaged yet.


Note You need to log in before you can comment on or make changes to this bug.