Bug 242582 - ext "mounting unchecked fs" warnings when mounting snapshots
ext "mounting unchecked fs" warnings when mounting snapshots
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Mikulas Patocka
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 17:51 EDT by Corey Marthaler
Modified: 2010-01-11 22:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 23:13:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2007-06-04 17:51:42 EDT
Description of problem:
Opening a rhel5 dup of bz 178705.

Version-Release number of selected component (if applicable):
2.6.18-18.el5/lvm2-2.02.16-3.el5
Comment 1 Mikulas Patocka 2008-06-10 23:12:57 EDT
Resolving this as WONTFIX because Ext2 design doesn't allow stabilizing the
filesystem while it is mounted. See explanation in bug 178705. There are two
major problems with it:

1. You can sync, but you can't prevent any concurrent updates while the sync is
in progress. Preventing concurrent updates would mean to add another lock to Ext2
and would kill performance.

2. Ext2 doesn't provide a method for removing open deleted inodes. The only way
to remove them is to run fsck.

Note You need to log in before you can comment on or make changes to this bug.