Bug 242591 - start hidd fails at boot
Summary: start hidd fails at boot
Status: CLOSED DUPLICATE of bug 230017
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-04 22:53 UTC by Brian G. Anderson
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 10:54:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian G. Anderson 2007-06-04 22:53:10 UTC
Description of problem:
starting hidd always fails with a "Can't listen on HID control channel: Address
already in use"


Version-Release number of selected component (if applicable):
bluez-utils-3.9-2.fc7

How reproducible:
always


Steps to Reproduce:
1. service hidd restart
2.
3.
  
Actual results:
start fails with message


Expected results:


Additional info:
This is a Dell Lattitude D620.  Bluetooth works and I can send an receive files
from my phone using obex-ftp.  This is a fresh install of FC7.

Comment 1 Brian G. Anderson 2007-06-04 23:04:06 UTC
After some experimentation,  I found that if I stop bluetooth services and then
start hidd it succeeds.  I can restart the bluetooth services after this. 
However, if I switch the order, hidd won't start.


Comment 2 Brian G. Anderson 2007-06-04 23:13:27 UTC
Curiously, once I stop bluetooth, restart hidd, and restart bluetooth,  I can
start and stop hidd with no further problems.

Comment 3 Evert Verhellen 2007-06-28 21:42:03 UTC
I can confirm Brian's workaround. I adjusted the startup priority of the HIDD
service from 26 to 24 and updated the symbolic links with "chkconfig hidd
resetpriorities". After rebooting, doing "hidd --search" discovers my Bluetooth
mouse correctly.

Comment 4 David Woodhouse 2007-07-21 10:54:28 UTC

*** This bug has been marked as a duplicate of 230017 ***


Note You need to log in before you can comment on or make changes to this bug.