Bug 242593 - RHN Web GUI chokes on German Umlauts (� � � �)
RHN Web GUI chokes on German Umlauts (� � � �)
Status: CLOSED DUPLICATE of bug 244707
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
https://rlx-3-20.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 248627
  Show dependency treegraph
 
Reported: 2007-06-04 18:58 EDT by Timo Trinks
Modified: 2007-10-10 10:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 10:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attempt 1 - Using plain German Umlauts (102.49 KB, image/jpeg)
2007-06-04 18:58 EDT, Timo Trinks
no flags Details
(In reply to comment #1) > Created an attachment (id=156149) [edit] Result 1 - German Umlauts displayed incorrectly (114.12 KB, image/jpeg)
2007-06-04 19:01 EDT, Timo Trinks
no flags Details
Result 1 - German Umlauts displayed incorrectly (109.77 KB, image/jpeg)
2007-06-04 19:03 EDT, Timo Trinks
no flags Details
Attempt 2 - Using entities for German Umlauts (114.12 KB, image/jpeg)
2007-06-04 19:08 EDT, Timo Trinks
no flags Details
Result 2 - Display of German Umlauts in form entered as entities OK (115.72 KB, image/jpeg)
2007-06-04 19:09 EDT, Timo Trinks
no flags Details

  None (edit)
Description Timo Trinks 2007-06-04 18:58:40 EDT
Description of problem:
RHN Web GUI chokes on German Umlauts (ä ü ö ß)

Version-Release number of selected component (if applicable):
latest

How reproducible:
Always

Steps to Reproduce:
1. Log in with language preferences set to German
2. Go to https://rlx-3-20.rhndev.redhat.com/rhn/account/Addresses.do
3. Enter address with umlauts in name
  
Actual results:
Umlauts are not displayed properly

Expected results:
Should be displayed properly using UTF-8

Additional info:
I used a workaround for all German Umlauts occuring in the GUI menues, pages,
etc. by formatting them as HTML entities (ü etc.). However, when
entering data through the address forms you can't expect a customer to use
entities for Umlauts themselves. See attached snapshots for details on the
problem...
Comment 1 Timo Trinks 2007-06-04 18:58:40 EDT
Created attachment 156149 [details]
Attempt 1 - Using plain German Umlauts
Comment 2 Timo Trinks 2007-06-04 19:01:21 EDT
Created attachment 156151 [details]
(In reply to comment #1)
> Created an attachment (id=156149) [edit]

Result 1 - German Umlauts displayed incorrectly
Comment 3 Timo Trinks 2007-06-04 19:03:58 EDT
Created attachment 156153 [details]
Result 1 - German Umlauts displayed incorrectly
Comment 4 Timo Trinks 2007-06-04 19:08:09 EDT
Created attachment 156154 [details]
Attempt 2 - Using entities for German Umlauts
Comment 5 Timo Trinks 2007-06-04 19:09:05 EDT
Created attachment 156155 [details]
Result 2 - Display of German Umlauts in form entered as entities OK
Comment 6 Justin Sherrill 2007-10-10 10:47:44 EDT

*** This bug has been marked as a duplicate of 244707 ***

Note You need to log in before you can comment on or make changes to this bug.