Bug 242608 - handler for ical files is 'evolution-2.0' which would be wrong, even if it did exist
handler for ical files is 'evolution-2.0' which would be wrong, even if it di...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-webcal (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 21:44 EDT by Luis Villa
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 13:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 320865 None None None Never

  None (edit)
Description Luis Villa 2007-06-04 21:44:17 EDT
So, to handle ical files, /usr/share/applications/defaults.list should point at
evolution-webcal . Instead, it points at evolution-2.0, which doesn't even
exist, and wouldn't work if it did. :) Probably this bug has to depend on the
existence of an evolution-webcal.desktop, but I'm not sure. I defer to your
excellence and wisdom, Mr. Nocera.
Comment 1 Luis Villa 2007-06-04 21:47:14 EDT
Sigh. I misfiled the version, and made an error in the bug as well; I'm not sure
that pointing it at evolution-webcal works either, since that doesn't work for
local files. Either way, evolution-2.0 is definitely not the solution that
you're looking for :)
Comment 2 Bastien Nocera 2007-08-21 06:12:33 EDT
Removed the following (broken) mappings in shared-mime-info for rawhide.

* Tue Aug 21 2007 - Bastien Nocera <bnocera@redhat.com> - 0.22-2
- Don't say that webcal files are handled by evolution-2.0, it can't
- Disable vCard mapping as well, as evolution doesn't handle it
  (See http://bugzilla.gnome.org/show_bug.cgi?id=309073)

Reassigning to evolution-webcal. It should install a .desktop file advertising
the webcal mime-types, and only handle URLs, so that clicking on a link in a
browser does the right thing.
Comment 3 Matthew Barnes 2007-08-21 21:27:26 EDT
I can click on this link [1] in my browser and Evolution asks me if I want to
subscribe to the calendar and then proceeds to add it to my Calendar component.

Maybe I'm misunderstanding the problem but what aspect of this is not working?

[1] webcal://engineering.redhat.com//program/rhel/rhel-5-2-0/rhel-5-2-0-event.ics
Comment 4 Matthew Barnes 2007-08-21 21:32:27 EDT
I guess Bugzilla doesn't recognize webcal URLs, but I can still go to [1] and
click the "GNOME" link to subscribe.  I'm using Fedora 7 with the Rawhide
Evolution packages:

   evolution-2.11.90-3.fc8
   evolution-webcal-2.10.0-1.fc8

[1] http://engineering.redhat.com/products.php/rhel/5/.2
Comment 5 Bastien Nocera 2007-08-21 21:38:50 EDT
Matthew, that works for "webcal://" type URLs, but doesn't for "http://" (when
we get a mime-type, etc.)

If you use webcal://, it will use the default URI handler for webcal from GConf,
and not do anything based on the mime-type.

Either click:
http://engineering.redhat.com//program/rhel/rhel-5-2-0/rhel-5-2-0-event.ics
Or download it locally and double-click.
Comment 6 Matthew Barnes 2007-08-21 21:45:04 EDT
Okay I see, thanks for clarifying Bastien.

Sounds like this should be moved upstream.
Comment 7 Matthew Barnes 2007-08-21 21:51:22 EDT
I did find this two-year-old upstream bug, but it kinda looks like dobey
stonewalled it.  Thoughts?

http://bugzilla.gnome.org/show_bug.cgi?id=320865
Comment 8 Luis Villa 2007-08-27 12:18:51 EDT
Sorry for lag, my account was disabled.

I guess there are two bugs here:
(1) evo-as-packaged-in-fedora/RHEL doesn't even try to load, since it points at
evolution-2.0, which doesn't exist. That should be fixed to point at something
else; probably evolution-webcal.
(2) evolution-webcal should probably work, but doesn't; that is upstream 320865.
Comment 9 Matthew Barnes 2007-08-27 13:21:28 EDT
Okay so it looks like Bastien already handled part (1) and even pinged the
upstream bug.  Any objection to me moving the remainder upstream?
Comment 10 Luis Villa 2007-08-27 13:27:45 EDT
Oh, I missed that.

(1) bad bastien- retitle the bug if you think it is now a different bug ;)
(2) all things considered, yeah, I guess the bug should be closed. Shame it
can't actually be fixed without smacking upstream about the head.
Comment 11 Matthew Barnes 2007-08-27 13:56:21 EDT
If Bastien or someone can suggest a reasonable workaround, I'm up for
maintaining it in Fedora/RHEL until upstream is, well, smacked.  I myself am not
wise in these matters.

In the meantime, closing this as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.