Bug 242622 - deskbar applet problems with bery
Summary: deskbar applet problems with bery
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: deskbar-applet (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 05:52 UTC by Jack Deslippe
Modified: 2016-09-20 02:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-14 19:29:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 438489 None None None Never

Description Jack Deslippe 2007-06-05 05:52:03 UTC
Description of problem:
I don't know if this problem is fixible.  But, I thought I would report it
anyway.  Basically Beryl and deskbar-applet don't play nice together.

When I am using Beryl Window manager and I click on the deskbar-applet (it opens
behind any maximized window).  And when I change the preference setting to
'entry in panel' from button, I cannot type in the box - hence making it unusable.  

Version-Release number of selected component (if applicable):
deskbar-applet-2.18.1-1.fc7
beryl-0.2.0-1.fc7

How reproducible:
Try to use deskbar-applet with beryl running ;)

Comment 1 Fedora Update System 2007-06-06 16:41:44 UTC
deskbar-applet-2.19.3-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 2 Luke Macken 2007-06-06 17:13:59 UTC
There is also a new version of beryl in updates-testing as well.

Not sure if this issue is fixable though.. as it seems pretty sporadic.  The
first click opens deskbar fine, then the next 4 open behind the window, then the
next above them.

Comment 3 Jack Deslippe 2007-06-07 03:35:36 UTC
Not fixed under the update to new deskbar-applet for me.  I didn't test under
new beryl as I am a bit scared to break my system.  I'll let you know when the
release hits the updates repo whether it fixed this issue or not.

Comment 4 Jack Deslippe 2007-07-14 07:30:04 UTC
This bug is fixed after installed Compiz-Fusion (which includes Compiz 0.5) from
Kagesenshi's repo see:  http://forums.fedoraforum.org/showthread.php?t=159056

This has completely fixed the bug with deskbar-applet (as well as several other
bugs I had with beryl).  Perhaps some effort should be made to get the
Compiz-Fusion packages into the official fedora repos.  


Comment 5 Luke Macken 2007-07-14 19:29:25 UTC
The switch to compiz-fusion is inevitable, since compiz+beryl have now combined.
 I'm closing this bug now since there is not much we can do about this issue at
this point in time, except to wait for compiz-fusion.


Note You need to log in before you can comment on or make changes to this bug.