Bug 242634 - ADSL connection timeout problems with F7
ADSL connection timeout problems with F7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rp-pppoe (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 03:47 EDT by Jamie Slooder
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 13:32:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Slooder 2007-06-05 03:47:30 EDT
Description of problem:

Activating ADSL no longer appears to work in Fedora 7 after using
the same hardware in FC 3 to FC 6.  There are continual timeouts and
the resulting connection is subsequently terminated.

Example errors from /var/log/messages:

pppd[3395]: pppd 2.4.4 started by root, uid 0
pppd[3395]: Using interface ppp0
pppd[3395]: Connect: ppp0 <--> /dev/pts/3
pppd[3395]: LCP: timeout sending Config-Requests
pppd[3395]: LCP: Connection terminated
pppd[3395]: LCP: Modem hangup
pppd[3395]: LCP: Timeout waiting for PADO packets
...etc

ADSL setup was done using /usr/sbin/pppoe-setup providing the same
data as in earlier versions of Fedora.

Full details of 2 people having the same problem (with debugging output
in 2nd report) are available at:

    http://forums.fedoraforum.org/showthread.php?p=803017

Version-Release number of selected component (if applicable):
rp-pppoe-3.8-1.fc7
ppp-2.4.4-2

To reproduce:

run /usr/sbin/adsl-start are configuring ADSL connection
with /usr/sbin/pppoe-setup
Comment 1 Jamie Slooder 2007-06-05 10:42:10 EDT
For some reason, this problem has now been solved by just re-installing PPP
from the Fedora 7 install DVD.  I.e.:

rpm -i --replacepkgs [path to ppp-2.4.4-2 RPM on Fedora 7 installation DVD]

Once that was done, adsl worked (i.e. no connection timeouts).

This solution was quite by accident.  I originally slotted in the FC6 binaries of
pppoe and pppd in the hope they'd work, but accidentally deleted the original
F7 version of pppd requiring me to re-install it from DVD.

So I guess this can be closed

Note You need to log in before you can comment on or make changes to this bug.