Bug 242661 - Xen requires glibc-devel.i386 on x86_64
Summary: Xen requires glibc-devel.i386 on x86_64
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Clark Williams
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 11:31 UTC by Mark McLoughlin
Modified: 2013-01-10 04:20 UTC (History)
2 users (show)

Fixed In Version: 0.7.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 08:18:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark McLoughlin 2007-06-05 11:31:33 UTC
Xen currently fails to build in x86_64 mock with the following failure:

  "No Package Found for /usr/include/gnu/stubs-32.h"

which in turn is caused by the "*-devel.i?86" exclude in mock's yum config.

Xen requires glibc-devel.i386 even on x86_84 because it needs to build the 32
bit BIOS firmware for HVM.

Comment 1 Mark McLoughlin 2007-06-05 15:03:13 UTC
Clark: it's perfectly valid for x86_64 xen to want to build against 32 bit
glibc, IMHO ... that's why I logged this against mock

What's the background on these excludes?

Comment 2 Jesse Keating 2007-06-05 15:22:03 UTC
You don't want all i386 stuff winding up in the buildroot.  Not sure why this
wasn't caught before, but glibc-devel should be the only package allowed into
the buildroot from the secondary arch.

Comment 3 Clark Williams 2007-06-05 16:48:47 UTC
Sorry for the confusion. I thought it as a mis-assignment for glibc and didn't
actually see that it was a mock bug. 


Comment 4 Fedora Update System 2007-06-14 21:11:53 UTC
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2007-06-21 20:03:41 UTC
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Jesse Keating 2007-06-21 20:09:22 UTC
0.7.1-1 doesn't actually fix this.  0.7.2 is coming that will.

Comment 7 Chris Lalancette 2008-02-29 04:12:10 UTC
It looks like this was fixed long ago.  Can we close this out?

Thanks,
Chris Lalancette

Comment 8 Mark McLoughlin 2008-02-29 08:18:48 UTC
Can't confirm that it works now, but looking at the excludes, it should be fine:

# grub/syslinux on x86_64 need glibc-devel.i386 which pulls in glibc.i386, need to
# exclude all .i?86 packages except these.
exclude=[A-Za-fh-z]*.i?86 g[A-Za-km-z]*.i?86 gl[A-Za-hj-z]*.i?86
gli[A-Zac-z]*.i?86 glib[A-Za-bd-z]*.i?86



Note You need to log in before you can comment on or make changes to this bug.