Bug 242673 - Removing firefox, removes dependency yelp; yelp is needed other places.
Summary: Removing firefox, removes dependency yelp; yelp is needed other places.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 12:32 UTC by Henning Kvello-Aune
Modified: 2018-04-11 10:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 14:41:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henning Kvello-Aune 2007-06-05 12:32:53 UTC
Description of problem:
Removing firefox, before installing firefox-32. Then dependency yelp was
removed: I think yelp is needed for other programs. 

Version-Release number of selected component (if applicable):
Fedora 7, with all updates. 

How reproducible:
Terminal: F1

Steps to Reproduce:
1. Try to get help; eg. F1 
2.
3.
  
Actual results:
Error

Expected results:
Help text

Additional info: yum install yelp

Comment 1 Matěj Cepl 2007-06-05 14:41:47 UTC
This is not a bug -- firefox serves two purposes in Fedora, it works as a
browser, and then it provides a lot of functionality to other programs (i.e., it
functions as a library of a kind). Yum then just does the right thing by
removing all packages which require firefox.

Other issue is that all Gnome using help should depend on yelp -- unfortunately
that mean, that I will have to file a hundred or so bugs against each package
which should depend on yelp, but it doesn't. Oh well. (and yes, the side issue
will be that when you remove firefox whole Gnome will go ;-)).

However, concerning this bug for firefox, it is NOTABUG.

Comment 2 Jesse Keating 2007-06-12 20:55:11 UTC
Also worth noting that firefox-32 requires both firefox.x86-64 and firefox.i386
installed.  It is only a wrapper script to enable you to launch the 32bit
version of firefox rather than the 64bit.  It is not meant to replace the 64bit
firefox.

Comment 3 Warren Togami 2007-06-12 21:03:04 UTC
(In other words, firefox-32 has nothing to do with the source of this problem.)


Note You need to log in before you can comment on or make changes to this bug.