Bug 242765 - [amd svm disabled] x86_64: kernel coredumps
[amd svm disabled] x86_64: kernel coredumps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 14:10 EDT by Leon Fauster
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 10:30:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detect svm disabled by bios (1.39 KB, patch)
2007-06-27 17:56 EDT, Avi Kivity
no flags Details | Diff

  None (edit)
Description Leon Fauster 2007-06-05 14:10:58 EDT
Description of problem:

- I installed FC7 freshly. I choosed an xen kernel etc.
Hardware is an Dell optiplex 740 (AhtlonX2 / SATA etc.)

After installation i noticed that the normal kernel was 
also installed. I rebooted the machine.

- Kernel core dumps on booting .

Normal kprintf-message are shown.

than init starts :

i see the "fedora welcome" string 
i also see "press I for interactive mode" etc.

shortly after this, kernel core dumps.

i can read something about 
 
"Process (udevd pid 496 , threadinfo etc. pp."


Notice: I can boot the kernel-xen !!


Version-Release number of selected component (if applicable):

kernel-headers-2.6.21-1.3194.fc7
kernel-xen-2.6.20-2925.9.fc7
kernel-2.6.21-1.3194.fc7

How reproducible:

Everytime 

Steps to Reproduce:

Reboot the system and boot kernel-2.6.21-1.3194.fc7
on a x86_64 machine (my is a dell optiplex 740)
  
Actual results:

Coredumps while init is starting udev

Expected results:

booting nicely

Additional info:

I can boot the kernel-xen !!
Comment 1 Chuck Ebbert 2007-06-05 14:29:04 EDT
We need the exact messages from the screen. Please boot in 50-line mode (add the
kernel parameter "vga=ask" and select 80x50) then take a picture of the panic
with a digital camera. upload that as an attachment to this bugzilla.
Comment 2 Leon Fauster 2007-06-05 15:50:17 EDT
Switching to vesa mode 80x50 doesnt help because
when INIT take the boot process they switch back
to, i dont know maybe 80x24 ?


Right now i haven't a camera here but i typed it down:
so no warranty 





R13: 0000000000000001 
R14: 0000000000000012 
R15: 0000000000001ac5
FS:   00002aaaab679710(0000) 
GS:   ffff81007fe8b940(0000) 
knlGS:0000000000000000

CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b

CR2: 0000555555769e90 CR3: 000000007f310000 CR4: 00000000000006e0
Process udevd (pid: 496, threadinfo ffff81007fd6a000, task ffff81007ecff040)
Stack: ffffffff802582ac ffff810037c87f78 81007fea30000080 000000000000ffff
0000000000000000 ffffffff80221bf7 0000000000000000 0000000000000053
00000000000002ad ffffffff80257c76 ffff81007fd6bd60 <EOI> 0000000000000043

CallTrace:

<IRQ> [<ffffffff802582ac>] call_softirq+0x1c/0x28

<From me: Without [< >]

ffffffff80221bf7 smp_call_function_interrupt+0x40/0x5e
ffffffff80257c76 call_function_interrupt+0x66/0x70
<EOI> ffffffff8033190e __first_cpu+0x3/0x1f
ffffffff8023f929 show_stat+0x2f5/0x3a0
ffffffff8023c694 seq_read+0x105/0x28c
ffffffff8020af0a vfs_read+0xcb/0x173
ffffffff80210606 sys_read+0x45/0x6e
ffffffff8025711e system_call+0x7e/0x83


Code: 0f30488b5620488b0a48c1e933 48 89 c8 48 c1 e8 09

RIP ffffffff8823932a : kvm_amd:svm_hardware_enable+0xa0/0x141
RSP ffff810037c87f68
kernel panic - not syncing : aiee , killing interrupt handler!




JFYI: I can boot kernel-2.6.21-1.3xxx from FC7RC2 LiveCD !
Comment 3 Leon Fauster 2007-06-05 16:47:05 EDT
I have tested this kernels:

kernel-2.6.21-1.3200.fc8 - doesnt work

kernel-2.6.21-1.3194.fc7 - doesnt work
i expected that at least this would work
because it is the same like the one on
FC7RC2-Live.iso

kernel-2.6.21-1.3116.fc7 - doesnt work
kernel-2.6.20-1.3104.fc7 - doesnt work

kernel-xen-2.6.20-2925.9.fc7 - does work

--

udev is on f7 and fc7rc2 the same (106-4.fc7)

--

my grub.conf

default=1
timeout=5
splashimage=(hd0,1)/boot/grub/splash.xpm.gz
hiddenmenu
password --md5 $1$nz2jA0d7$qZGgWbA8bqopvb3eQPZbJ.
title Fedora (2.6.21-1.3116.fc7)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.21-1.3116.fc7 ro root=LABEL=/
        initrd /boot/initrd-2.6.21-1.3116.fc7.img
title CasaRoot (2.6.20-2925.9.fc7xen)
        root (hd0,1)
        kernel /boot/xen.gz-2.6.20-2925.9.fc7 
        module /boot/vmlinuz-2.6.20-2925.9.fc7xen ro root=LABEL=/
        module /boot/initrd-2.6.20-2925.9.fc7xen.img
Comment 4 Chuck Ebbert 2007-06-05 16:51:00 EDT
(In reply to comment #2)
> Switching to vesa mode 80x50 doesnt help because
> when INIT take the boot process they switch back
> to, i dont know maybe 80x24 ?
>

Yeah, it loads the stupid default font and that forces it back to 80x25.
That can be disabled (the easy way) by renaming /lib/kbd/consolefonts
to something else during testing.
 
> Right now i haven't a camera here but i typed it down:
> so no warranty 
> RIP ffffffff8823932a : kvm_amd:svm_hardware_enable+0xa0/0x141
> RSP ffff810037c87f68

You should be able to boot by blacklisting the kvm_amd module.
Edit /etc/modprobe.d/blacklist and add it.
Comment 5 Leon Fauster 2007-06-05 17:29:58 EDT
I had kernel-2.6.21-1.3116.fc7 installed 

I.
i first modified /etc/modprobe.d/blacklist 
then updated the kernel to kernel-2.6.21-1.3194.fc7
and rebooted - blacklisting kvm_amd doenst help.
 
II.
i removed drivers/kvm dir, then i rebuild
the kernel dependencies and rebooted. This worked !!!


Being in 2.6.21-1.3194 i restored the drivers/kvm dir
and rebuilded the kernel dependencies again.

so - doing manualy modprobe kvm_amd killed the box.

for now - kvm_amd triggers these freezes.

so far - thank you - but one eye is crying because
i was planning to setup this box as a virt server ,)
 
Good Night (here is midnight)
Comment 6 Leon Fauster 2007-06-10 12:20:44 EDT
The latest dev kernel (2.6.21-1.3218.fc8.x86_64)
also gets panic if i load the kvm-amd modul.
Comment 7 Avi Kivity 2007-06-10 14:10:11 EDT
If virtualization is enabled in the BIOS, disable is.
If it is enabled, disable it :)

And let us know what happens.
Comment 8 Leon Fauster 2007-06-27 17:40:38 EDT
About the BIOS: There is no possibility for change any 
virtualization option. it dosnt offer it. 

By the way - should we change the bug title - now where we 
known what it caused?
Comment 9 Avi Kivity 2007-06-27 17:56:58 EDT
Created attachment 158069 [details]
detect svm disabled by bios

The attached patch fixes this.
Comment 10 Chuck Ebbert 2007-06-27 18:11:29 EDT
Patch went into kernel 3237
Comment 11 Leon Fauster 2007-06-28 16:00:56 EDT
I tried kernel-2.6.21-1.3240.fc8.x86_64 and kernel-2.6.21-1.3228.fc7.x86_64.

The difference to the other tested kernels - it passes the point where init starts udev.

After booting - no kvm* module is loaded.

Loading kvm-amd manually ends in a kernel panic.
Comment 12 Chuck Ebbert 2007-06-28 16:07:30 EDT
Patch is in kernel 1.3237.fc7

fc8 is following upstream and still doesn't have this fix.
Comment 13 Leon Fauster 2007-06-28 16:54:50 EDT
Where to find 1.3237.fc7 kernel?

I searched in development/x86_64/os/Fedora/, updates/testing/7/x86_64/, 
updates/7/x86_64/ and http://people.redhat.com/cebbert/kernels/!
Comment 14 Chuck Ebbert 2007-06-28 17:19:42 EDT
(In reply to comment #13)
> Where to find 1.3237.fc7 kernel?

Not released, some kernel after 3237 will be released soon.
Comment 15 Chuck Ebbert 2007-06-29 12:17:46 EDT
(In reply to comment #9)
> Created an attachment (id=158069) [edit]
> detect svm disabled by bios
> 
> The attached patch fixes this.

Avi, this patch is broken on 32-bit.

See bug #246250
Comment 16 Chuck Ebbert 2007-07-06 16:39:10 EDT
Patch is in kernel 2.6.21-1.3255.fc7, in updates-testing now.
Comment 17 Leon Fauster 2007-07-10 16:13:06 EDT
# uname -a
Linux casa.localdomain 2.6.21-1.3255.fc7 #1 SMP Thu Jul 5 18:03:06 EDT 2007 x86_64 x86_64 
x86_64 GNU/Linux

# modprobe kvm

# modprobe kvm-amd
kvm: disabled by bios
FATAL: Error inserting kvm_amd (/lib/modules/2.6.21-1.3255.fc7/kernel/drivers/kvm/kvm-amd.ko): 
Operation not supported

# lsmod |head
Module                  Size  Used by
kvm                    75969  0 
autofs4                32841  2 
sunrpc                188329  1 
ipv6                  340289  16 
cpufreq_ondemand       17489  1 
dm_mirror              30209  0 
dm_mod                 69713  1 dm_mirror
video                  28113  0 
sbs                    25729  0 


Well as the message above stated - kvm stuff is unusable and no 
bios options exists for enabling it. 

Is it  possible to bypass the bios and enabling it while booting?
Comment 18 Chuck Ebbert 2007-07-10 16:17:53 EDT
There is no way to override the BIOS settings for svm. The patch is doing its
job and preventing a kernel crash when svm is disabled -- that's all it can do.
Comment 19 Ian Collier 2007-09-04 09:42:13 EDT
This appears to be still broken on kernel-2.6.22.4-65.fc7 - is this a new branch
that doesn't include the above fix?

2.6.21-1.3228.fc7 (which is before the fix) does boot, usually, but always
outputs a kernel traceback while starting udev.  The newer kernel panics every time.

For anyone reading this who has an HP machine (dc5750 here with BIOS 2.20), I
found the BIOS option that controls virtualization technology - it's in Security
-> OS Security.  Setting this to Enable fixes the oops.

There's a kvm-devel thread about the same problem (no patch, though):
http://www.mail-archive.com/kvm-devel@lists.sourceforge.net/msg03890.html

Note You need to log in before you can comment on or make changes to this bug.