Bug 242800 - xorg dies on startup with glint_drv.so: undefined symbol: RamDacCreateInfoRec
xorg dies on startup with glint_drv.so: undefined symbol: RamDacCreateInfoRec
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 16:48 EDT by Matt Albrecht
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0.0-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 18:08:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (13.20 KB, text/plain)
2007-06-05 16:48 EDT, Matt Albrecht
no flags Details

  None (edit)
Description Matt Albrecht 2007-06-05 16:48:49 EDT
Description of problem:

xorg server fails on startup (when running "startx") due to:

X: symbol lookup error: /usr/lib/xorg/modules/drivers//glint_drv.so: undefined
symbol: RamDacCreateInfoRec

I'm running with a FireGL 1000 video card, which seems to limit me to only the
glint driver.


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg.i386 1.3.0.0-5.fc7


How reproducible:

Happens every time I attempt to start X.

Steps to Reproduce:
1. run "startx"

  
Actual results:
   X switches the display to the X buffer (Ctrl-Alt-F7), but it remains blank. 
The X server stops on the primary console with the above error message.

Expected results:
    X server should start

Additional info:
    I've attached the Xorg log file.
Comment 1 Matt Albrecht 2007-06-05 16:48:50 EDT
Created attachment 156276 [details]
xorg log file
Comment 2 Need Real Name 2007-06-06 18:17:00 EDT
I'm experiencing the same problem with a Permedia 2 card.  Same symbol lookup 
error.

Research suggests it might be caused by this xorg bug, which is resolved 
upstream: https://bugs.freedesktop.org/show_bug.cgi?id=10906

I'm in the process of recompiling the xorg-x11-server SRPM with the patch from 
there, and I'll report back when I find out whether it works.
Comment 3 Need Real Name 2007-06-06 18:36:04 EDT
OK, I grabbed xorg-x11-server-1.3.0.0-5.fc7.src.rpm, added the patch from the 
freedesktop.org bug entry, rebuilt the RPM and installed it.  Now the X server 
starts.
Comment 4 Fedora Update System 2007-06-07 11:57:31 EDT
xorg-x11-server-1.3.0.0-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Matt Albrecht 2007-06-07 15:27:42 EDT
I just tried out the xorg-x11-server-Xorg update from the development repository
(version i386 1.3.0.0-8.fc8) since I didn't see the update yet in the testing
repository (it's at -7.fc7 when I checked, which doesn't have the fix).  I'm
seeing the X server start now.
Comment 6 Need Real Name 2007-06-07 20:10:04 EDT
I just installed xorg-x11-server-Xorg-1.3.0.0-8.fc7 from testing, and it works 
here.
Comment 7 Fedora Update System 2007-06-11 18:08:03 EDT
xorg-x11-server-1.3.0.0-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.