Bug 242802 - X windows exits on laptop lid event
X windows exits on laptop lid event
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 16:55 EDT by Phil Clayton
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 15:46:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 8776 None None None Never

  None (edit)
Description Phil Clayton 2007-06-05 16:55:38 EDT
Description of problem:

X windows exits and restarts when the laptop lid is closed.

This issue is acknowledged with Ubuntu:
https://bugs.launchpad.net/ubuntu/edgy/+source/xorg-server/+bug/61746

Furthermore, the issue is acknowledged as an xorg problem and has been resolved:
https://bugs.freedesktop.org/show_bug.cgi?id=8776

However, despite using the latest FC6 udpates, I am still affected by this
problem.  Thus my problem is actually that this update to xorg has not been
incorporated into fc6 updates!


Version-Release number of selected component (if applicable):

I am using xorg-x11-server-Xorg-1.1.1-47.8.fc6.  Looking at the source in
xorg-x11-server-1.1.1-47.8.fc6.src.rpm, the issues exists with
xorg-server-1.1.1/hw/xfree86/os-support/linux/lnx_acpi.c and I could not see a
patch for it...


How reproducible:

Every time.


Steps to Reproduce:

Close laptop lid whilst X running.

  
Actual results:

X windows exits and restarts.


Expected results:

X windows does not exit and selected power-saving behaviour occurs.


Additional info:

none
Comment 1 Adam Jackson 2007-07-09 15:46:22 EDT
This should be fixed in xorg-x11-server 1.1.1-47.10.fc6.  Please test, and
reopen if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.