Bug 242803 - Repoview crashes on F7/Python 2.5
Summary: Repoview crashes on F7/Python 2.5
Status: CLOSED DUPLICATE of bug 232590
Alias: None
Product: Fedora
Classification: Fedora
Component: repoview   
(Show other bugs)
Version: 7
Hardware: All Linux
high
low
Target Milestone: ---
Assignee: Konstantin Ryabitsev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 21:02 UTC by Christoph Wickert
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 23:19:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christoph Wickert 2007-06-05 21:02:12 UTC
Description of problem:
repoview crashes on F7 because it needs to be updated for Python 2.5.

Version-Release number of selected component (if applicable):
repoview-0.5.2-1.fc6 (sic!)

How reproducible:
always

Steps to Reproduce:
1. install Fedora 7 and repoview
2. put some RPMs into a folder and run createrepo
3. run repoview
  
Actual results: Repoview crashes because it can't find python-elementtree, that
is included in Python 2.5 now.
$ repoview
Traceback (most recent call last):
File "/usr/bin/repoview", line 40, in <module>
from elementtree.SimpleXMLWriter import XMLWriter
ImportError: No module named elementtree.SimpleXMLWriter 

Expected results: Something like
$ repoview .
Reading repository data...done
parsing primary: 52 packages, 0 ignored...done
parsing other: 52 packages, 0 ignored...done
creating extra groups: 52 entries...done
copying layout...done
writing groups: 13 written, 0 preserved
writing letter groups: 9 written, 0 preserved
writing packages: 52 written, 0 preserved
generating index...done
writing checksum...done
Moving new repoview dir in place...done

Comment 1 Konstantin Ryabitsev 2007-06-05 23:19:03 UTC

*** This bug has been marked as a duplicate of 232590 ***


Note You need to log in before you can comment on or make changes to this bug.