Bug 242810 - perl-Net-Server: repoclosure problem because perl-IO-Multiplex is not available
perl-Net-Server: repoclosure problem because perl-IO-Multiplex is not available
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: perl-Net-Server (Show other bugs)
el4
All Linux
medium Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 17:58 EDT by Bernard Johnson
Modified: 2007-06-18 14:07 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.96-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 14:07:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2007-06-05 17:58:00 EDT
Description of problem:
perl-Net-Server depends on perl-IO-Multiplex but perl-IO-Multiplex is not
available for el4.

Version-Release number of selected component (if applicable):
perl-Net-Server-0.96-1.el4

How reproducible:
Always

Steps to Reproduce:
1. yum install perl-Net-Server
2. or yum update if it's already installed
3.
  
Actual results:
# yum update
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Net-Server.noarch 0:0.96-1.el4 set to be updated
--> Running transaction check
--> Processing Dependency: perl(IO::Multiplex) for package: perl-Net-Server
--> Finished Dependency Resolution
Error: Missing Dependency: perl(IO::Multiplex) is needed by package perl-Net-Server
Comment 1 Bernard Johnson 2007-06-16 18:20:26 EDT
This appears to be a simple fix... 

either

a) request perl-IO-Multiplex to be branched and built for epel4

or

b) change requires on perl(IO::Multiplext) to:
# build for epel5 using perl(IO::Multiplex)
%{?el5: Requires: perl(IO::Multiplex)}


I don't see the point in allowing the repository to be broken for long periods
of time - especially for epel.
Comment 2 Nicolas Mailhot 2007-06-16 20:02:28 EDT
Oops, I'm not supposed to handle Net-Server EPEL bugs, seems the default
bugzilla owner is wrong

Anyway: IO::Multiplex is in FE and F≥7. It's an optional run-time dep. Fedora
Net::Server depends on IO::Multiplex because IO::Multiplex is available in the
Fedora repo (see bug #174099). Indeed latest Fedora-Devel added IO::Multiplex as
BR so corresponding tests are run at build time.

EPEL can do the same of choose not to depend on IO::Multiplex. That's really up
to the EPEL maintainer. I personally would not have bumped the EPEL Net::Server
version over the version of the package in the Fedora release corresponding RHEL
was derived from (or at least taken the Fedora Devel package as source instead
of branching from an old package), so obviously our packaging styles differ.

Comment 3 Kevin Fenzi 2007-06-18 11:44:54 EDT
So sorry about this everyone. ;( 

I should have been listed as the epel owner, not sure what happened there, but I
will get it fixed up. 

I will get this cleaned up asap. 
Comment 4 Kevin Fenzi 2007-06-18 14:07:18 EDT
ok. Owner should be set now. 

I have pushed new builds that hopefully fix this issue. 
Please let me know if you spot any further problems. 

Sorry again for the delay here. 

Note You need to log in before you can comment on or make changes to this bug.