Bug 242821 - display corrupted when switching to graphical mode
display corrupted when switching to graphical mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 19:29 EDT by Jack Spaar
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 20:04:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log (48.49 KB, text/plain)
2007-06-05 19:29 EDT, Jack Spaar
no flags Details
And here's my Xorg.0.log. (50.81 KB, text/plain)
2007-09-04 14:48 EDT, Jan Pazdziora
no flags Details
trivial xorg.conf (564 bytes, text/plain)
2007-10-05 14:20 EDT, Jack Spaar
no flags Details
server log for no-configfile case (47.65 KB, text/plain)
2007-10-05 14:36 EDT, Jack Spaar
no flags Details

  None (edit)
Description Jack Spaar 2007-06-05 19:29:02 EDT
Description of problem:
Sometimes when switching to graphical mode (either manually from a terminal via
alt-f7, or automatically whenever the server is started or reset), the display
appears corrupted.  Specifically, certain colors get messed up.  The white "f"
part of the fedora logo turns black, desktop icon names have noisy black/white
borders.

Manually switching to text mode and back usually cures the issue.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-2.0.2-2.fc7

How reproducible: about 1 time in 20


Steps to Reproduce:
1. switch to a text console (alt-f1) then back to the graphical mode (alt-f7)
2.
3.
  
Actual results:
Certain colors are wonky.

Expected results:


Additional info:
Xorg.0.log attached.

This can also happen whenever the server is started, either when booting into
level 5, or when the server is restarted after a session logout, or when the
server is restarted via alt-backspace.

This is a clean install of F7 on hardware (GeForce 6200) that worked normally
under FC6.
Comment 1 Jack Spaar 2007-06-05 19:29:02 EDT
Created attachment 156294 [details]
server log
Comment 2 Matěj Cepl 2007-09-04 08:22:32 EDT
Looks interesting -- could we get /etc/X11/xorg.conf as well? What happens when
you have no /etc/X11/xorg.conf whatsoever and you restart X?

(BTW, for airlied, whom I am going to assign this bug, we've got reproduction of
this bug from a developer in the Brno office).
Comment 3 Adam Jackson 2007-09-04 12:53:46 EDT
I don't think this is anything to do with configuration.  It looks more like the
palette is getting stomped either on EnterVT or LeaveVT.
Comment 4 Jan Pazdziora 2007-09-04 14:47:27 EDT
Yep, there is probably some problem in the code. I'm observing the same with my
GeForce 6200. For the record, my config is

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Comment 5 Jan Pazdziora 2007-09-04 14:48:37 EDT
Created attachment 186421 [details]
And here's my Xorg.0.log.
Comment 6 Matěj Cepl 2007-10-05 09:36:39 EDT
Jack?
Comment 7 Jack Spaar 2007-10-05 14:20:06 EDT
Created attachment 217771 [details]
trivial xorg.conf

Sorry for the hit and run -- somehow BZ emails weren't getting to me until this
morning.

Attached my xorg.conf, but it's trivial.

Also, this problem is sometimes triggered by gnome-screensaver's fade-to-black,
even if it gets interrupted by pressing a key before blanking completely.

Also, when the problem is active, if I run a small program which changes video
mode to 8-bit and then changes back on exit, the problem is cleared.
Comment 8 Jack Spaar 2007-10-05 14:36:35 EDT
Created attachment 217801 [details]
server log for no-configfile case

It took me 5 minutes to confirm that the problem occurs without any xorg.conf
file.  Log attached.
Comment 9 Jack Spaar 2007-11-17 20:04:02 EST
This seems to be fixed for nv in F8.  (It happens for nouveau on F8 instead.)
Close as nextrelease?

Note You need to log in before you can comment on or make changes to this bug.