Bug 242826 - pgadmin3 1.6.3 does not connect to postgres 8.2.4 database
pgadmin3 1.6.3 does not connect to postgres 8.2.4 database
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pgadmin3 (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 20:21 EDT by Bob Gustafson
Modified: 2008-01-19 20:49 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 20:49:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
GUI of pgadmin - see not connected (47.55 KB, image/jpeg)
2007-06-05 20:21 EDT, Bob Gustafson
no flags Details

  None (edit)
Description Bob Gustafson 2007-06-05 20:21:05 EDT
Description of problem:

I start pgadmin and 'add server', put in the connection details and click on OK.
The dialog box immediately disappears.

When I start pgadmin again, it has the database icon with a big red X. The
properties indicate that pgadmin is not connected to the database. (see attached
image)

  When I look in the postgres log file, the newest line sa:d:
  LOG:  unexpected EOF on client connection

Version-Release number of selected component (if applicable):

  pgadmin3 - 1.6.3-1.fc7.i386

  postgresql - 8.2.4-1.fc7.i386

How reproducible:

  pgadmin was working a month ago (with postgresql 8.1.9)

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:

  pgadmin disappears

Expected results:

  pgadmin should connect to my database

Additional info:

 There may be format changes in the 8.2.4 version of postgresql that pgadmin3
hasn't caught up with as yet.

  There was a complaint when I tried to start postgresql when I finally was able
to boot into Fedora7. Something about a database format change between the
version of postgresql installed in Fedora6 and that loaded in Fedora7.

This is another bug as the Fedora7 upgrade process overwrites the old version of
postgresql and then issues an error message saying that it cannot open the old
format database - please pg_dumpall and reload with the new system.
Unfortunately, for pg_dumpall to work, postgresql must be running on the database.

I had to move the data, uninstall postgres 8.2.4, install postgresql 8.1.9,
pg_dumpall, uninstall 8.1.9, reinstall 8.2.4 and then import the dumpall file.
Comment 1 Bob Gustafson 2007-06-05 20:21:06 EDT
Created attachment 156295 [details]
GUI of pgadmin - see not connected
Comment 2 Joshua Daniel Franklin 2007-11-14 13:09:10 EST
This works for me with pgadmin3-1.8.0 built from upstream SRPM:

http://ftp7.us.postgresql.org/pub/postgresql//pgadmin3/release/v1.8.0/fedora-7/srpm/

I am connecting to postgresql-8.2.5-1.fc7 on another Fedora 7.
By the way, I'm not saying it's your fault, but it's not a bad 
idea to pg_dumpall nightly with logrotate unless your databases 
are huge. 
Comment 3 Devrim GUNDUZ 2007-11-14 13:50:36 EST
Agreed, and this bug is invalid -- at least it is not a bug.
Comment 4 Tom Lane 2007-11-14 13:51:35 EST
That makes it probably a pgadmin issue not a postgres server issue.  Reassigning ...
Comment 5 Devrim GUNDUZ 2007-11-14 22:55:45 EST
Submitted 1.8.0 to Fedora 7. It will appear in a few days. 

Bob, could you please install it when it is available in the repos and test it?

Comment 6 Bob Gustafson 2007-11-15 01:29:36 EST
pgadmin3 1.8.0 beta 5 works for me.

I need to run it from the command line. The Fedora menu pgadmin3 points to the
old version.
Comment 7 Fedora Update System 2007-11-15 19:40:15 EST
pgadmin3-1.8.0-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.