Bug 242841 - livecd-creator doesn't work (version 009.1.fc7)
Summary: livecd-creator doesn't work (version 009.1.fc7)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 03:50 UTC by Luis Felipe Marzagao
Modified: 2013-03-06 03:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 01:48:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attachment created with strace command (608.18 KB, application/x-gzip)
2007-06-06 03:50 UTC, Luis Felipe Marzagao
no flags Details

Description Luis Felipe Marzagao 2007-06-06 03:50:26 UTC
Description of problem:

F7 fresh install. I try to create the minimal livecd wth livecd-creator and it
simply stops. Some errors described below are shown.


Version-Release number of selected component (if applicable):

[root@localhost ~]# yum list | grep -i livecd-tools
livecd-tools.noarch                      009-1.fc7              installed

How reproducible:


Steps to Reproduce:
1. Fresh install F7
2. yum install -y livecd-tools
3. Try the suggested line in help to create a minimal live cd
4. [root@localhost ~]# livecd-creator
--config=/usr/share/livecd-tools/livecd-fedora-minimal.ks

  
Actual results:

[root@localhost ~]# livecd-creator
--config=/usr/share/livecd-tools/livecd-fedora-minimal.ks
mke2fs 1.39 (29-May-2006)
Filesystem label=livecd-20070606-
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
524288 inodes, 1048576 blocks
10485 blocks (1.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1073741824
32 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks: 
        32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done                            
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 23 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
tune2fs 1.39 (29-May-2006)
Setting maximal mount count to -1
Setting interval between checks to 0 seconds
No Repositories Available to Set Up

(nothing happens now... It simply stays stopped for hours and hours...)

If I get luck to make the "ctrl+c" stop the application, I get:

Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 1088, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 1069, in main
    target.install()
  File "/usr/bin/livecd-creator", line 871, in install
    self.installPackages(self.packages, self.epackages, self.groups)
  File "/usr/bin/livecd-creator", line 479, in installPackages
    map(lambda pkg: self.ayum.selectPackage(pkg), packageList)
  File "/usr/bin/livecd-creator", line 479, in <lambda>
    map(lambda pkg: self.ayum.selectPackage(pkg), packageList)
  File "/usr/bin/livecd-creator", line 215, in selectPackage
    self.install(pattern = pkg)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1759, in install
    parsePackages(self.pkgSack.returnPackages(),[kwargs['pattern']] , casematch=1)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 297, in
returnPackages
    return self._computeAggregateListResult("returnPackages")
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 369, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 670, in
returnPackages
    if self._excluded(repo,x['pkgId']):
KeyboardInterrupt


Expected results:

The minimal livecd should be created.


Additional info:

strace file output attached

PS: I could not find the section "livecd-tools" in red hat bugzilla. That's why
I created the entry under LiveCD

Comment 1 Luis Felipe Marzagao 2007-06-06 03:50:27 UTC
Created attachment 156309 [details]
Attachment created with strace command

Comment 2 Jeremy Katz 2007-06-07 15:50:29 UTC
It looks like it's waiting on an rpm lock -- can you reboot, rm -f
/var/lib/rpm/__db* and try again?

Comment 3 Luis Felipe Marzagao 2007-06-07 23:29:25 UTC
Okay, just rebooted, erased all the __db files with the command suggested and
tried again. Same thing is happening. It stays stopped right after the "No
Repositories Avaiable to Set Up" message... 


[root@localhost ~]# ll -a /var/lib/rpm/*
-rw-r--r-- 1 rpm rpm  5308416 2007-06-07 03:18 /var/lib/rpm/Basenames
-rw-r--r-- 1 rpm rpm    12288 2007-06-05 02:32 /var/lib/rpm/Conflictname
-rw-r--r-- 1 rpm rpm  1609728 2007-06-07 03:18 /var/lib/rpm/Dirnames
-rw-r--r-- 1 rpm rpm  5275648 2007-06-07 03:18 /var/lib/rpm/Filemd5s
-rw-r--r-- 1 rpm rpm    24576 2007-06-07 03:18 /var/lib/rpm/Group
-rw-r--r-- 1 rpm rpm    16384 2007-06-07 03:18 /var/lib/rpm/Installtid
-rw-r--r-- 1 rpm rpm    40960 2007-06-07 03:18 /var/lib/rpm/Name
-rw-r--r-- 1 rpm rpm 31555584 2007-06-07 03:18 /var/lib/rpm/Packages
-rw-r--r-- 1 rpm rpm   344064 2007-06-07 03:18 /var/lib/rpm/Providename
-rw-r--r-- 1 rpm rpm    98304 2007-06-07 03:18 /var/lib/rpm/Provideversion
-rw-r--r-- 1 rpm rpm    12288 2007-06-02 21:01 /var/lib/rpm/Pubkeys
-rw-r--r-- 1 rpm rpm   413696 2007-06-07 03:18 /var/lib/rpm/Requirename
-rw-r--r-- 1 rpm rpm   204800 2007-06-07 03:18 /var/lib/rpm/Requireversion
-rw-r--r-- 1 rpm rpm    90112 2007-06-07 03:18 /var/lib/rpm/Sha1header
-rw-r--r-- 1 rpm rpm    45056 2007-06-07 03:18 /var/lib/rpm/Sigmd5
-rw-r--r-- 1 rpm rpm    12288 2007-06-07 00:04 /var/lib/rpm/Triggername


Comment 4 Luis Felipe Marzagao 2007-06-19 01:48:13 UTC
I don't think that was a bug. After redirecting livecd-creator to collect rpms
from a localrepo the cd was created ok. I think it was taking too long because
the packages were being downloaded from the internet and since there's no
progress bar the user gets the sensation the program has halted.

Changing status to notabug.


Note You need to log in before you can comment on or make changes to this bug.