Bug 242864 - scim-bridge starts scim in English IME
Summary: scim-bridge starts scim in English IME
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-bridge   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Peng Huang
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 05:25 UTC by Jens Petersen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 11:40:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2007-06-06 05:25:35 UTC
Description of problem:
The newest scim-bridge seems to have a locale problem.
The first time scim-bridge starts for a new

How reproducible:
every time

Steps to Reproduce:
1. login into Asian desktop as new user (ie no ~/.scim/)
2. start gtk application (eg gedit)
3. trigger scim with Ctrl+space
  
Actual results:
3. scim toolbar appears with "English/European"

Expected results:
3. start with Japanese Anthy IME.

Additional info:
This does not happen in F7.
It may be related to some locale code changes in scim-1.4.6
but this does not happen with scim-gtk (ie im-scim.so).

Comment 1 Peng Huang 2007-08-07 02:58:52 UTC
The reason is that scim-agent program does not call setlocale.
fixed in 0.4.13-2.

Comment 2 A S Alam 2007-09-14 11:40:20 UTC
it starts in ja_JP during selection of ja_JP language during login
tested with following RPM:
scim-bridge-0.4.13-4.fc8


Note You need to log in before you can comment on or make changes to this bug.