Bug 242882 - user cannot automatically mount cd/dvd and usb drives under KDE sessions
user cannot automatically mount cd/dvd and usb drives under KDE sessions
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2007-06-06 04:28 EDT by Alexey Sorokin
Modified: 2008-06-16 21:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
sorted list all my rpms (27.25 KB, text/plain)
2007-06-12 09:48 EDT, Alexey Sorokin
no flags Details
error message after FC4-> F7 upgrade (31.06 KB, image/png)
2007-06-13 14:09 EDT, Alexey Sorokin
no flags Details
rpms list from another buggy system, FC4->F7 upgrade (22.66 KB, text/plain)
2007-06-13 14:10 EDT, Alexey Sorokin
no flags Details
dialog box (11.05 KB, image/png)
2007-06-21 15:15 EDT, Steve Falco
no flags Details

  None (edit)
Description Alexey Sorokin 2007-06-06 04:28:45 EDT
Description of problem:
user cannot automatically mount cd/dvd and usb drives under KDE sessions

Under gnome all work fine, but if you are using KDE - not.
You insert usb stick (or just DVD disk), see "new usb drive" notify, click on
"open in new window" - and get error "Don't have permission: Not in current
I believe, main reason is ConsoleKit: 
"- gdm got ConsoleKit integration 
- Need patches for kdm and other KDE components too"
Comment 1 David Zeuthen 2007-06-06 11:38:45 EDT
Sounds like a kdm bug to me (assuming you're using kdm) - it should already have
been fixed FWIW. Reassigning. 
Comment 2 Alexey Sorokin 2007-06-06 13:52:53 EDT
1) No, it's not a kdm bug. I started kde session from gdm - the same trouble.
2) No, it's not already have been fixed. I make yum update before submit this
bug, my F7 install is fully up-2-date.
Comment 3 Ngo Than 2007-06-11 07:46:51 EDT
Alexey, i cannot reproduce this issue with F7 release. I'm using KDM.
Could you please give me a testcase how i can reproduce this problem? Thanks
Comment 4 Stefano Cavallari 2007-06-11 19:04:19 EDT
I have the same problem. Maybe it just happen when updating?
I updated from FC6 using the dvd.
Alexey: New install or update? 

I made a new user and the problem is still there, so there is nothing lurking in
my home directory. 
Comment 5 Alexey Sorokin 2007-06-12 09:48:47 EDT
Created attachment 156794 [details]
sorted list all my rpms
Comment 6 Alexey Sorokin 2007-06-12 09:50:50 EDT
Stefano, I updated from FC5 using the dvd too.
In attach - sorted list all my rpms.
Today I plan to made some tests with update and clean install FC7, and I'll post
results here.
Comment 7 Alexey Sorokin 2007-06-13 09:02:33 EDT
Very strange: I cannot reproduce this bug on clean install FC6 and upgrade to F7..
Next plan: try to upgrade FC3/4/5->F7 and look on results again.
May be lists of rpms from clean systems may be helpful? Any another ideas?
Comment 8 Alexey Sorokin 2007-06-13 14:08:20 EDT
I have one reproduced upgrade FC4->F7.
On next 2 attached files - another form of error message (one user have this
one, second - standard "Not in active session") and rpms list from this system.
One idea: I need to test upgrade "full install" FC6->F7, not only custom minimal
install, that I did before. I'll check this tomorrow.
Comment 9 Alexey Sorokin 2007-06-13 14:09:27 EDT
Created attachment 156896 [details]
error message after FC4-> F7 upgrade
Comment 10 Alexey Sorokin 2007-06-13 14:10:38 EDT
Created attachment 156897 [details]
rpms list from another buggy system, FC4->F7 upgrade
Comment 11 Stefano Cavallari 2007-06-13 16:35:48 EDT
I'm trying to understand what keeps the login manager from registering the kde
session with ConsoleKit.
ck-list-sessions shows no session at all.
In http://people.freedesktop.org/~mccann/doc/ConsoleKit/ConsoleKit.html the
steps which a login manager should do are explained.
I can't understand where in a Fedora system the dbus-calls are actually done. If
I get more info I might be able to tell what should be fixed, or better fix it
Comment 12 Stefano Cavallari 2007-06-13 18:03:49 EDT
a full selinux relabeling made things work.
Alexey: can you confirm this?

If it's the case, I think it should be added to F7 release notes.
Comment 13 Alexey Sorokin 2007-06-14 01:41:55 EDT
No, this trick don't help me.
On all my installations I always switch SELinux off, for relabeling I switch it
on -> reboot (nothing changed - user still get "Not in active session" error),
after this I switch SELinux off again -> one more reboot -> bug still have place..
Comment 14 Stefano Cavallari 2007-06-14 08:46:13 EDT
what does "ck-list-sessions print" ? (under kde of course)
Comment 15 Alexey Sorokin 2007-06-14 08:51:03 EDT
inside Konsole:
[sofa@as ~]$ ck-list-sessions print
        uid = '501'
        realname = ''
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2007-06-14T09:15:14Z'
Comment 16 Stefano Cavallari 2007-06-14 15:04:43 EDT
It's another different problem then. I never had ck-list-session list anything
before the relabeling.
Sorry I can't be of much help at this point as I don't know enough of D-Bus and
Comment 17 Alexey Sorokin 2007-06-18 16:12:24 EDT
Unfortunately, I'm still unable to provide a testcase for clean install/upgrade procedure..
But on fedoraforum.org somebody have found quick fix solution: http://forums.fedoraforum.org/
Comment 18 Steve Falco 2007-06-21 15:15:59 EDT
Created attachment 157563 [details]
dialog box
Comment 19 Steve Falco 2007-06-21 15:16:31 EDT
I believe I have the same problem, with a usb flash drive.  I am using F7 with
KDE as my desktop, logging in via gdm.  If I do:

cat /var/lib/hal/acl-list | grep sd

there is no output, so the device, /dev/sdb1, is not in the list.

Running ck-list-sessions shows the following, so I have an active session.

        uid = '4059'
        realname = 'Steven A. Falco'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty8'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2007-06-21T18:46:36Z'

My system is fully patched as of today.

As another comment reported, manually adding a line to /etc/fstab allows the
mount to succeed.  In my case I added:

/dev/sdb1 /media/wd auto noauto,user,exec 0 0

but this is a poor solution because with usb devices, the /dev entry can change
based on how many devices are plugged in.

I'm attaching a screen shot of the exact dialog box.
Comment 20 Aurelien Bompard 2007-06-27 15:32:17 EDT
Any news on this front ? I appear in ck-list-sessions and yet I can't mount
flash drives as a user. Fully up-to-date, including updates-testing (KDE 3.5.7)
Comment 21 Jean-pierre Cartal 2007-07-20 04:25:54 EDT
Same issue for me here after upgrading from FC5.
Before SELinux relabeling, ck-list-sessions was not returning anything.
Now that relabeling has been done ck-list-sessions returns the correct
informations but I'm still unable to automount DVD/CD/USB drives.
In the meantime I manually added entries in the /etc/fstab as suggested by
Steve, but I agree that this is not an optimal solution.
Comment 22 Artem S. Tashkinov 2007-09-27 07:12:28 EDT
I have the same problem (autofs is not installed) and in Fedora Core 6
everything worked fine.

Strangely consolekit thinks I'm logged on twice:

[birdie@localhost ~]$ ck-list-sessions print
        uid = '500'
        realname = ''
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2007-09-26T09:21:18Z'
        uid = '500'
        realname = ''
        seat = 'Seat2'
        session-type = ''
        active = FALSE
        x11-display = ':0'
        x11-display-device = ''
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2007-09-26T09:21:18Z'

Permission denied: not in active session.
Comment 23 Bug Zapper 2008-05-14 08:51:04 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 24 Bug Zapper 2008-06-16 21:26:54 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.