Bug 242892 - Need F7 gpsd package, can't get 1PPS running on F7
Need F7 gpsd package, can't get 1PPS running on F7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Matthew Truch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 05:30 EDT by David
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 07:26:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2007-06-06 05:30:57 EDT
Description of problem:
On FC6 ntpq-p with a stock kernel reportede 1PPS as primary, and non 1PPS as
secondary.

However since upgrading to F7 can not get 1PPS working.

Filed other bugs against the kernel and ntp, but need this done as well, as
there are 3 things that could be the issue.
Kernel bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242211
ntp bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242891

Version-Release number of selected component (if applicable):


How reproducible:
1PPS never worked on F7 but did on FC6

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
1PPS needs to work on F7

Additional info:
Comment 1 David 2007-06-06 07:27:22 EDT
Corrupted package, I yum removed gpsd, yum clean all and yum install gpsd and
got the f7 package.
Comment 2 Matthew Truch 2007-06-06 07:42:24 EDT
Glad you just had a bunk pacakge and figured it out quickly.  I was at a loss as
to what could have caused this, as the gpsd pacakge has changed little since FC6.  
Comment 3 David 2007-06-06 07:51:39 EDT
No problems!  It was strange sorry for the headache.

It came up as I still cant get 1PPS working on F7.  It worked perfectly on FC6,
stock non xen kernel, Motorola Encore GPS in nmea mode and the 1PPS connected to
DCD via line driver.

Now I cant get 1PPS working.  I got three bugs on this and it looks like a
kernel issue.

selinux no ntpd policy:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242215

kernel issue:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242211

ntp cant 1PPS with gpsd
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242891

If you got any ideas please share :)   

Note You need to log in before you can comment on or make changes to this bug.