Bug 242922 - screen memory corruption with vnc/i810
Summary: screen memory corruption with vnc/i810
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 13:48 UTC by Henrique Martins
Modified: 2018-04-11 10:14 UTC (History)
1 user (show)

Fixed In Version: f7+updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 16:29:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corrupted display (34.68 KB, image/gif)
2007-06-06 13:50 UTC, Henrique Martins
no flags Details
xorg.conf (2.99 KB, text/plain)
2007-06-06 13:51 UTC, Henrique Martins
no flags Details
Xorg.0.log (61.19 KB, text/plain)
2007-06-06 13:52 UTC, Henrique Martins
no flags Details

Description Henrique Martins 2007-06-06 13:48:28 UTC
vnc'ing into the main display, using libvnc extension module seems to corrupt
screen memory.  This machine is on FC6, nightly patched.  Very few, if any,
non-fedora repos used.  Graphics is Intel i810.

Random occurrences, always same are of the screen. Sometimes it's there,
sometimes is not, even on successive invocations.

I'll attach images of the display, the xorg.conf used and the Xorg.0.log at the
time.

Comment 1 Henrique Martins 2007-06-06 13:50:45 UTC
Created attachment 156350 [details]
corrupted display

Comment 2 Henrique Martins 2007-06-06 13:51:44 UTC
Created attachment 156351 [details]
xorg.conf

Comment 3 Henrique Martins 2007-06-06 13:52:07 UTC
Created attachment 156352 [details]
Xorg.0.log

Comment 4 Matěj Cepl 2007-12-10 09:22:52 UTC
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Comment 5 Henrique Martins 2007-12-10 16:29:59 UTC
Can't replicate with F8+updates.  Can't pinpoint when it disappeared, but
probably in late F7+updates.

Comment 6 Lindsay Holmwood 2007-12-17 03:47:12 UTC
I had the same problem as you, added the following line to the Device section of
my xorg.conf, and the corruption went away:

Option      "LinearAlloc"   "16384"


Note You need to log in before you can comment on or make changes to this bug.