Bug 242924 - Bug 232765: Active Connections not displayed
Summary: Bug 232765: Active Connections not displayed
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firestarter   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Damien Durand
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 14:35 UTC by Keith Dixon
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 05:08:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes other ip_conntrack references (2.04 KB, patch)
2007-06-28 14:10 UTC, Sertaç Ö. Yıldız
no flags Details | Diff

Description Keith Dixon 2007-06-06 14:35:08 UTC
Description of problem:

Bug 232765: Active Connections not displayed

Has returned

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 dex 2007-06-21 17:22:13 UTC
Can this bug not be marked a duplicate of 232765.

Comment 2 dex 2007-06-22 02:51:13 UTC
This patch brings back Active Connections.

--- firestarter-1.0.3/src/statusview.c        2005-01-29 12:32:08.000000000 +0000
+++ firestarter-1.0.3/src/statusview-new.c    2007-06-21 19:56:55.000000000 +0100
@@ -32,7 +32,7 @@

 #define DEV_FILE "/proc/net/dev"
 #define TCP_FILE "/proc/net/tcp"
-#define CONNTRACK_FILE "/proc/net/ip_conntrack"
+#define CONNTRACK_FILE "/proc/net/nf_conntrack"
 #define CONNTRACK_TTL 10 /* Number of refresh cycles a non-established
connection is kept in the GUI */
 #define REFRESH_RATE 1 /* Time in seconds between updates */
 #define HISTORY_LENGTH 5 /* Number of samples to use when averaging the traffic
rate */



Comment 3 Sertaç Ö. Yıldız 2007-06-28 14:10:28 UTC
Created attachment 158125 [details]
fixes other ip_conntrack references

here's a more complete patch.

Comment 4 dex 2007-06-28 19:04:54 UTC
cool I was just getting round to that...



Note You need to log in before you can comment on or make changes to this bug.