Bug 242945 - Some xfce panel plugins can't be added
Some xfce panel plugins can't be added
Status: CLOSED DUPLICATE of bug 228168
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
: Desktop, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 12:04 EDT by Samuel Bizien
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 15:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "yum list xfce4-*" (3.35 KB, application/octet-stream)
2007-06-06 12:58 EDT, Samuel Bizien
no flags Details

  None (edit)
Description Samuel Bizien 2007-06-06 12:04:32 EDT
Description of problem:
Can't add some plugins to XFCE panel, many of them (and the most important ones
!) doesn't work. When I try to add this plugins to my panel, it only says
"impossible to create <plugin> element on panel" (err .. translated literrally
from french :s ). Plugins that bugs :
 - launcher
 - showdesktop
 - iconbox
 - pager
 - clock(datetime works)
 - windowlist
 - tasklist
 - systray
 - separator

Other plugins, such as weather or cpuload work well.

Version-Release number of selected component (if applicable):
XFCE: 4.4.1-1.fc7
quicklauncher: 1.9.2-3.fc7
taskmanager : 0.4.0-0.2.rc2.fc6 (??)
There's no xfce4-systray, xfce4-iconbox, or other RPMs named like that installed
on my system (and they are not available on default fedora repos).

How reproducible:
Install XFCE, and try to add one of the plugins listed before.

Actual results:
An error box saying that it couldn't create the plugin I asked for.

Expected results:
Just work.

Additional info: I'm using f7.x86_64, I don't know if there's a bug on i386.
I re-used my /home (created with fc6), but these bugs also appears when I create
a new user.
Comment 1 Kevin Fenzi 2007-06-06 12:51:24 EDT
Can you provide the output of a: 

yum list 'xfce4-*' ?

I have had another report of some oddness going on on x86_64 installs. 
I suspect you might have the i386 versions of the plugins, but the x86_64 panel. 
Comment 2 Samuel Bizien 2007-06-06 12:58:44 EDT
Created attachment 156371 [details]
output of "yum list xfce4-*"

The list shows that i386 packages installed are only '-panel' and '-session'
(but x86_64 version is also installed for both).
Comment 3 Kevin Fenzi 2007-06-06 14:15:38 EDT
ok. This is a xfce4-panel bug with multilib. 

It's already been filed as bug #228168. 

I am working now to fix it up... in the mean time as a work around, can you: 

- remove the xfce4-panel.i386
- remove the xfce4-panel.x86_64
- re-install the xfce4-panel.x86_64 only. 

ie, 'yum remove xfce4-panel.i386 xfce4-panel.x86_64' then 'yum install
xfce4-panel.x86_64'

It should then all work. 
Comment 4 Samuel Bizien 2007-06-06 14:47:48 EDT
Worked well, thanks :) .

What I've done:
# yum remove xfce4-panel.i386
# rpm -e xfce4-panel.x86_64 --nodeps
# yum install xfce4-panel

Comment 5 Christoph Wickert 2007-06-06 15:03:52 EDT
I can confirm that the panel is pretty much broken on x86_64: Default panels are
completely empty except from the xfce-menu. None of the plugins in your list is
showing up in the "Add Items to the Panel" dialog, but at least quicklauncher
works after removing the i386 version of xfce4-panel. So it's definitely not the
plugin but the panel itself. This is why I'll close this bug a duplicate of bug
#228168 now.

*** This bug has been marked as a duplicate of 228168 ***

Note You need to log in before you can comment on or make changes to this bug.