Bug 242950 - DVB-T stick not recognized when having ehci_hcd modprobed
Summary: DVB-T stick not recognized when having ehci_hcd modprobed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FCMETA_USB
TreeView+ depends on / blocked
 
Reported: 2007-06-06 16:33 UTC by Martin Jürgens
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: kernel-2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 08:48:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Jürgens 2007-06-06 16:33:17 UTC
Description of problem:
My Freecom DVB-T stick is not recognized when having ehci_hcd modprobed.

Version-Release number of selected component (if applicable):


How reproducible:
Not Every Time.

Steps to Reproduce:
1. Plug it in
  
Actual results:
Nothing happens, logs say:

dvb-usb: WideView WT-220U PenType Receiver (Typhoon/Freecom) successfully
deinitialized and disconnected.
usb 3-2: new high speed USB device using ehci_hcd and address 5
usb 3-2: device descriptor read/64, error -71
usb 3-2: device descriptor read/64, error -71
usb 3-2: new high speed USB device using ehci_hcd and address 6
usb 3-2: device descriptor read/64, error -71
usb 3-2: device descriptor read/64, error -71
usb 3-2: new high speed USB device using ehci_hcd and address 7
usb 3-2: device not accepting address 7, error -71



Expected results:
DVB-T stick should work, firmware should be loaded on it by linux kernel
(indicated by led on device).

Additional info:
After unmodprobing ehci_hcd the led is turned on and logs say that the firmware
has been put on the device. Of course, I can not watch TV because USB1 is far
too slow for this. (ehci_hcd is for USB2 support afaik)

Comment 1 Christopher Brown 2007-09-13 22:54:41 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

I have re-assigned this to the usb subsystem maintainer and added a USB blocker
bug which should hopefully generate some interest.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 2 Martin Jürgens 2007-09-14 08:48:35 UTC
Christopher, thank you for your work on triaging kernel bugs.

I do not encounter the problem anymore with the latest 2.6.22 kernel in Fedora 7.


Note You need to log in before you can comment on or make changes to this bug.