Bug 242960 - NetworkManager fails to start (missing libiw.so.28)
Summary: NetworkManager fails to start (missing libiw.so.28)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 17:32 UTC by Nicolò
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 19:23:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolò 2007-06-06 17:32:31 UTC
Description of problem:
NetworkManager fails to start (both at boot and after login) and complains 
about missing shared lib: libiw.so.28

Version-Release number of selected component (if applicable):
NeworkManager 1:0.6.5-3.fc7

How reproducible:
Always

Steps to Reproduce:
1.boot
2.OR
3.just type NetworkManager in a root shell
  
Actual results:
"NetworkManager: error while loading shared libraries: libiw.so.28: cannot 
open shared object file: No such file or directory"
Obviously eth0 will not work

Expected results:
NetworkManager should start

Additional info:
I don't have any libiw in my computer, and couldn't find any libiw***.rpm, 
maybe a dependency is missing?

BTW If I manually ifup eth0, it just works.

Comment 1 Christopher Aillon 2007-06-06 18:17:52 UTC
It should be in the wireless-tools package....  wonder why you don't have that,
the dependencies should have picked it up.

Comment 2 Nicolò 2007-06-06 19:01:41 UTC
Installing wireless-tools solved the problem, I wonder why I didn't have it 
installed too (maybe because I don't have a Wireless device, but I don't think 
the installer makes this kind of guess...)

I think this could be closed, thanks for the fast reply...

Comment 3 Christopher Aillon 2007-06-06 19:23:32 UTC
K, closing out.

Also for future reference, if you know the name of the file you need, you can
always do something like:

  yum install /usr/lib/libiw.so.28


Note You need to log in before you can comment on or make changes to this bug.