Bug 243011 - another copy is running as pid
Summary: another copy is running as pid
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
: 243186 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 21:52 UTC by Need Real Name
Modified: 2014-01-21 22:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 18:20:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2007-06-06 21:52:26 UTC
Whenever I run yum -y upgrade (and not sometimes, not once, but always), I get
the error:
 Existing lock /var/run/yum.pid: another copy is running as pid XXXX. Aborting.


# strace  -p 2893
Process 2893 attached - interrupt to quit
gettimeofday({1181166722, 862123}, NULL) = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x91090a8, FUTEX_WAKE, 1)         = 0
gettimeofday({1181166722, 862740}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 1000) = 0
gettimeofday({1181166723, 862575}, NULL) = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x91090a8, FUTEX_WAKE, 1)         = 0
gettimeofday({1181166723, 863162}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 1000) = 0
gettimeofday({1181166724, 862585}, NULL) = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x8cd5170, FUTEX_WAKE, 1)         = 0
futex(0x91090a8, FUTEX_WAKE, 1)         = 0
gettimeofday({1181166724, 863155}, NULL) = 0
poll( <unfinished ...>
Process 2893 detached

# ps axw|grep yum
 2893 ?        SN     0:03 /usr/bin/python /usr/sbin/yum-updatesd
 4501 pts/1    S+     0:00 grep yum
[root@sb-home ~]# yum -y upgrade
Loading "presto" plugin
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "protectbase" plugin
Setting up Presto
Reading Presto metadata in from local files
Loading mirror speeds from cached hostfile
Existing lock /var/run/yum.pid: another copy is running as pid 2893. Aborting.

Comment 1 Jeremy Katz 2007-09-13 18:20:10 UTC
yum-updatesd in Fedora 8 has been reworked to "hog" the lock file quite a bit
less which should help this.  Assuming testing continues to go well, I'll be
releasing    

Comment 2 Jeremy Katz 2007-09-13 18:21:44 UTC
*** Bug 243186 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.