This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 243015 - Folding@Home program seg faults
Folding@Home program seg faults
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 17:56 EDT by Darwin H. Webb
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 16:50:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2007-06-06 17:56:53 EDT
Description of problem:
Can not determine why Folding@Home program seg faults on these kernels
sig 11.
everything is the same from fc7 kernel 3194

Seperate user for fah
fah dir is on vg-lv of FC6 system and is monuted under the f7 fah mountpoint
i.g. mount /dev/mapper/vg21-lv06home /home/fahuser/fahmnt
at famnt cd down
cd fah
/.fahprgramnae.exe

the execmem and execstk selinux booleans are on by default in f7 (shock)
in fc6 the are set and reminder setroubleshoot pops up if they are not.

With the newer f8 kernels no setroubleshoot alert, no audit messages
no messages
pam shows fahprogm abnorm abend seg 11
 



Version-Release number of selected component (if applicable):
f7 with a few updates (using f7 kernel 3194 or (f8 kernel )

How reproducible:
everytime

Steps to Reproduce:
1. Install f8 kernel and bootup start fah sig 11
2.
3.
  
Actual results:


Expected results:


Additional info:

Darwin
Comment 1 Chuck Ebbert 2007-08-06 14:39:10 EDT
Signal 11 can be caused by bad memory, overheating CPU, inadequate power
supply and a long list of other reasons. Are you sure the hardware is 100%
OK? Do any other programs cause a problem? Has memtest86 been run on this
hardware?
Comment 2 Darwin H. Webb 2007-08-22 16:34:34 EDT
This bug can be closed.
With the high summer temps and the Virtual-Box running several systems,
I was able to pin point the problem a cpu heat (mainly when the FAH is using the
FPU @ 100% for a few hours VS> the VB using normal CPU @ irregular intervals
avg. 84%.)

I also think the 23 kernel is way better than any since 18. :)

Thanks,

Darwin

Note You need to log in before you can comment on or make changes to this bug.