Bug 243021 - Hard disk doesn't spin down on poweroff
Summary: Hard disk doesn't spin down on poweroff
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 7
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2007-06-06 22:09 UTC by Stefano Cavallari
Modified: 2007-11-30 22:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-07-22 00:32:51 UTC

Attachments (Terms of Use)

Description Stefano Cavallari 2007-06-06 22:09:04 UTC
Description of problem:
When I power off my laptop I hear a loud click from the hd, in the same way as
if I powered it off using the switch. 
That is what is called emergency parking of heads, and could damage hardware in
the long run.

Version-Release number of selected component (if applicable):
kernel 2.6.21-1.3194.fc7
using pata_sis, though I *think* the bug affects any ata drive.

How reproducible:

Steps to Reproduce:
1. Start the power off sequence
2. Listen to the hd
3. Become worried

Additional info:
In fc6 this didn't happen. It's probably because F7 kernel is using new pata
drivers instead of the plain old ide driver.
I marked the Severity as High as HDs (especially laptop's) are rated for a
limited number of emergency parkings.

Comment 1 James Ettle 2007-06-08 16:26:39 UTC
Eck! Not good, got this here too. kernel-2.6.21-1.3194.fc7 just told the
notebook to power down and simply yanked the plug on the hard disc. I've an
Intel 82801DBM (ICH4-M) controller using the ata_piix driver connected to a
FUJITSU MHT2060AT. I'm switching back to a kernel using the old IDE code in the

Comment 2 James Ettle 2007-06-09 13:48:22 UTC
This may not strictly be a kernel issue: see http://linux-ata.org/shutdown.html
; possibly a problem in sysvinit or initscripts?

Comment 3 Stefano Cavallari 2007-06-09 15:45:23 UTC
I think you are right. I'm changing the component for this bug to SysVInit
(which contains /sbin/shutdown)

Comment 4 James Ettle 2007-06-09 17:23:29 UTC
Understood. Although reading through the kernel Bugzilla
http://bugzilla.kernel.org/show_bug.cgi?id=7838 it seems that the 2.6.22 release
upstream will have stuff to fix this as well. I'm going to try the suggested
patch and see what happens.

Comment 5 Andre Robatino 2007-06-10 02:44:15 UTC
  Roughly how many emergency parkings are desktop and/or laptop HDs rated for? 
(I have a desktop.)  Just to get a sense of how fast this needs to be fixed.

Comment 6 Alexey Titov 2007-06-10 05:50:05 UTC
Please be fast :-)

Comment 7 James Ettle 2007-06-11 11:47:00 UTC
Dang, tried patch, didn't work (apparently doesn't cover PATA). Should've read
the notes more carefully! 

Comment 8 James Ettle 2007-06-12 14:45:55 UTC
Can anybody raise the priority of this bug from "low"?

Comment 9 Stefano Cavallari 2007-06-12 21:51:26 UTC
I'm setting the component back to "kernel", as it's where the problem is
Doesn't matter if it can be worked around in userspace, kernel or both. 
I looked at the kernel bugzilla and the bug (7838) is marked as
resolved_code_fix, though I can't find the patch itself. (only the scsi one, but
not the libata-specific one).
I've looked in git (scsi-misc-2.6) too, but I can't find anything related to
this to test.

PS: this is *NOT* a forum, so add a comment only if you know something new. 
If you just need help or something use http://www.fedoraforum.org/
Comments like "be fast" just spams the developers which are fixing bugs,
including this one!

Comment 10 Stefano Cavallari 2007-06-14 13:30:04 UTC
I found some patches for 2.6.21 to solve this issue:

Comment 11 Stefano Cavallari 2007-06-14 19:49:24 UTC
kernel-2.6.21-1.3228.fc7 still have the bug.

Comment 12 James Ettle 2007-06-14 20:47:51 UTC
Nice find, Stefano. Those patches worked for me (patched against vanilla and

Comment 13 Stephen E Clark 2007-06-19 21:02:25 UTC
Can't someone from redhat implement these changes in Fedora?


Comment 14 Manuel Moran 2007-06-29 10:10:14 UTC
This also happens when hibernating. 

On my Toshiba Satellite A200 I get a loud crack noise from disk heads, which
clearly means that hardware is suffering. 

This could produce hard disk failure, just out of software misbehaviour. We'd be
so glad to see a fix.

Comment 15 James Ettle 2007-06-29 10:56:07 UTC
I think this bug should be marked as a duplicate of Bug 242799.

Comment 16 Stephen E Clark 2007-06-29 11:50:12 UTC
They are related but not the same. It would really be nice if we could get
someone to step up an fix this problem since it been known about for a couple of

Comment 17 Chuck Ebbert 2007-07-06 18:16:36 UTC
Kernel 2.6.21-1.3255 is in testing now with patches to fix this. Please test.

Comment 18 Chuck Ebbert 2007-07-06 18:36:21 UTC
(Update kernels are in the updates-testing repository.)

As root:

  yum --enablerepo=updates-testing update kernel

Comment 19 Andre Robatino 2007-07-06 18:55:49 UTC
  A message just appeared in fedora-package-announce notifying of a test update
for this kernel.  Normally, this mailing list is only for updates-released.  Is
this a mistake, or has it actually been released?


Comment 20 Chuck Ebbert 2007-07-06 18:58:54 UTC
(In reply to comment #19)
>   A message just appeared in fedora-package-announce notifying of a test update
> for this kernel.  Normally, this mailing list is only for updates-released.  Is
> this a mistake, or has it actually been released?

That was a glitch in the announcement processing. The kernel is in testing.

Comment 21 Stephen E Clark 2007-07-06 19:28:31 UTC
[root@joker4 ~]# yum --enablerepo=updates-testing update kernel
Loading "installonlyn" plugin
Setting up Update Process
Could not find update match for kernel
No Packages marked for Update/Obsoletion

current kernel is:
[root@joker4 ~]# uname -r

Comment 22 Chuck Ebbert 2007-07-06 19:44:35 UTC
Kernel may not have mirrored out yet.

I found the i386 "normal" kernel here, so it is released:

Comment 23 Stephen E Clark 2007-07-08 17:56:30 UTC
In my testing it fixed my problem. I tried both a shutdown -r now and a shutdown
-h now - and my 
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -
      87 - stayed at 87.
I did a smartctl to find out what it was. Then did a shutdown -r now. Checked
and it was still 87 - I then did a shutdown -h now. Powered back on and checked
again and it was still 87. In the past it had always incremented , plus made a
loud click.

Now I haven't ran the kernel at all but it fixed this problem for me.

Comment 24 Manuel Moran 2007-07-10 15:11:33 UTC
This testing kernel fixed the problem for me. My Power-Off_Retract_Count remains
now the same as stated above (comment #23) and the click is not heard anymore.

I have to run the testing kernel (if I run the current one, I still get the clicks)

Thanks very much

Comment 25 Stephen E Clark 2007-07-17 18:57:14 UTC
Hey where did this kernel go 3255 - i have another system with the same problem
but this kernel is

Comment 27 Serguei Miridonov 2007-07-20 02:38:55 UTC fixes the problem on Compaq Presario 900

Comment 28 Andre Robatino 2007-07-21 01:57:42 UTC
  The kernel- in updates-released fixes it for me on a Dell
Dimension B110.

Comment 29 Manuel Moran 2007-07-21 10:24:00 UTC
The kernel- in updates-released fixes it on a Toshiba Satellite A200

It may be a good idea to add Fedora to the list of fixed distros here (none as
of yet):


Comment 30 Stefano Cavallari 2007-07-22 00:32:51 UTC fixes it for me too on my Asus A6km.
I think I can close this bug now. 

Note You need to log in before you can comment on or make changes to this bug.