Bug 243036 - dvd+rw-format exits with status 0 on failure
Summary: dvd+rw-format exits with status 0 on failure
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 23:55 UTC by Jonathan Kamens
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 11:08:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to exit with non-zero status when child process fails (309 bytes, patch)
2007-06-07 00:25 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2007-06-06 23:55:15 UTC
Using dvd+rw-tools-7.0-3.fc7.

$ dvd+rw-format -blank /dev/hdc
* BD/DVD±RW/-RAM format utility by <appro@fy.chalmers.se>, version 7.0.
* 4.7GB DVD-RW media in Sequential mode detected.
* blanking .:-[ READ TRACK INFORMATION failed with SK=3h/ASC=57h/ACQ=00h]:
Input/output error
$ echo $?
0
$ 

Since it failed, it should have exited with non-zero status.

Comment 1 Jonathan Kamens 2007-06-07 00:25:26 UTC
Created attachment 156413 [details]
patch to exit with non-zero status when child process fails

Fix attached.


Note You need to log in before you can comment on or make changes to this bug.